locked
UI become slow and unresponsive when changing Environment Font RRS feed

  • Question

  • Hello all,

    Using Ultimate 2013 on a VM, due to my eyes I need to increase the Font Size of Various areas within the UI. When I changed the Environment font size from the default to 14, the User interface becomes unresponsive. I was working with a large project at the time, so I killed V.S. and restarted with no solution opened and still the same thing. When I returned the Environment Font back to default, I could do my work again..

    Two things I noticed after I increased the font size

    1. the solution explore would continually bounce up and down

    2. clicking on anything I would have to wait 3 minutes for a respone

    3. When no project was opened at start up, the UI would start to cycle between UI sizes (full screen, normal), and the window title would show "not responsive".

    Has anyone run into this before? Most other methods of increasing the font (zoom, etc) don't really work for me.. 

    Any suggestions?

    Thanks!

    Friday, April 6, 2018 6:36 PM

All replies

  • >Has anyone run into this before? Most other methods of increasing the font (zoom, etc) don't really work for me.. 

    It's not something I've done before, but I've just tried changing that setting under VS2017 and I can't see any obvious problems as
    you describe. The only thing that hasn't worked correctly is that a second change of font hasn't taken effect on the Properties
    window - that's still showing the first font change - though restarting VS has sorted that out.

    Dave

    Friday, April 6, 2018 10:05 PM
  • Hi Thomas,

    Welcome to the MSDN forum.

    Usually, when we go to Tools-Options-Environment-Fonts and Colors, change the Size to ‘14’ and save, it only effects the Editor screen, not includes other windows. Could you please share the screenshot in here?

    Please have a try with the following to troubleshoot this issue;

    1. Restart the computer and open VS 2013

    2. Open cmd and navigate to the VS 2013 installation folder like C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE and run the command: devenv /safemode to run it as safe mode, then check if the installed extensions caused this issue.

    3. Go to go to Tools>Import and Export Settings>Reset all settings, back up your current setting and choose ‘General’ to restore to the default setting, then change the font size again and create a new project to have a try.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, April 9, 2018 9:24 AM
  • The only thing that hasn't worked correctly is that a second change of font hasn't taken effect on the Properties
    window - that's still showing the first font change - though restarting VS has sorted that out.

    Here's a bug report on that minor issue:
    https://developercommunity.visualstudio.com/content/problem/238921/properties-panel-font-doesnt-change-immediately-wh.html

    Dave

    Tuesday, April 24, 2018 12:04 AM