none
VS 2017 Setup Project bootstrapper prompts to install .NET 4.7.2 on machines where it should not RRS feed

  • Question

  • I have projects that require .NET 4.7.2, and have Visual Studio installer projects set up to include this version of the framework as a prerequisite. Unfortunately, the Framework installer starts to run even on computers running the October update of Windows 10, which already have the 4.7.2 version as part of the OS. The Framework installer does not run to completion but rather gets part of the way through and closes, after which my application does then proceed to install and run correctly.

    Has anyone else seen this before? Is there some additional configuration I need to change to only have the Framework installer begin if 4.7.2 is not present on the current operating system?

    Tuesday, April 2, 2019 3:04 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    The .NET Framework 4.7.2 is included in Windows 10 October 2018 Update and Windows 10 April 2018 Update, so you don't have to deploy it with your app on those operating systems.

    https://docs.microsoft.com/en-us/dotnet/framework/deployment/deployment-guide-for-developers

    I test this on windows 7 system, VS 2017 Setup Project bootstrapper doesn’t prompt to install .NET 4.7.2.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, April 3, 2019 9:39 AM
  • Yes, I understand that I don't have to deploy it with the app to those Windows 10 operating systems. However, my app can be installed on both Windows 7 and Windows 10, so we have the Framework bootstrapped in the setup.exe so it will be installed if it is not present. It should therefore not be prompting to install on Windows 10, but it is.

    Wednesday, April 3, 2019 2:22 PM
  • Hi Heather_E,

    I redirected your case to appropriate forum to seek for a more professional support, Thank you for your patience.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 4, 2019 9:58 AM
  • Hi Heather_E,

    Maybe you can try to handle it with silent install, here is a example you can refer to: Update regarding silent install of the VC 8.0 runtime (vcredist) packages.

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 9, 2019 7:37 AM
    Moderator