how can i find "msvcr100.dll" ?

    General discussion

  • hi all..
    i'm turkis so sorry for my bad english ..but i hope u understand me
    i wanted to install vs2005 on my vista os(sp1) and read the readme file ..then i uninstall all the programs which are recomended to uninstall ..
    then i started to istall vs2005..but i saw this error : "
     application has failed to start because MSVCR100
    dll was 
    installing the application may fix the problem

    please help me ..
    • Moved by Anutthara - MSFT Sunday, August 16, 2009 7:01 PM q regarding older vs version install (From:Microsoft Visual Studio Team System 2010 Beta 1)
    • Changed type YiChun Chen Thursday, August 20, 2009 3:28 AM Do not follow up
    Saturday, August 15, 2009 11:02 PM

All replies

  • Hi Rizarose,

    Firstly, please use Verification Tool to verify .Net Framework 2.0. If .Net Framework 2.0 cannot be verified on your computer, you can try to follow the steps mentioned in the following blog to repair the .NET Framework 2.0 on Windows Vista.

    Secondly, if the NET Frameworks is successfully verified, could you please try to use collect tool to collect the log files of Visual Studio 2005 from your "%temp%" folder?

    You can upload your log files to SkyDrive and post the link back here.

    - Try to clean your "%temp%" folder
    - Install Visual Studio 2005
      (The installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
    - Upload file

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, August 17, 2009 10:06 AM
  • Hi Rizarose,

    We are changing the issue type to “Comment” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, August 20, 2009 3:28 AM
  • m the shi all
    i'm the same who asked this question but i forgeted my password so i created another one
    so i will update the log file for u
    let me explain more clearly for u
    once i tried to install vs 2010 it successfully installed
    and then i saw that i have not msdn liberary and for that i uninstall vs 2010 and tried to install vs 2005 (with msdn liberary)
    i read the read me file of vs said to me that i must uninstall some things such as(.net framwork 2 and sql server and .. about 7-8 cases)
    i uninstall all of them and started to intall vs2005 ..but this time i saw that error..
    i dont know what is this file(msvcr100.dll) ?
    and how can i find it
    plz let me save log file once i try to reinstalling vs 2005 and upload it 
    any help will greatly appreciated
    Tuesday, September 01, 2009 6:44 PM
  • hi again
    now u can see my error log file on this link :

    and i think its better to uplaod the screen capture of my control panel/all installed programs
    : see this

    tanx alot
    Wednesday, September 02, 2009 10:22 AM
  • you must full uninstall net framework 4.0 (full and client profile). Then VS 2008 installed success !!!
    Monday, October 12, 2009 7:34 AM
  • After installing Visual Studio Express 2010 Beta 2 I also got the missing msvcr100.dll. I never got this issue in Windows XP x86, it only happened to me in Win7 x64.

    My solution was simple: Place/Copy the DLL in the System32 folder. I found a local copy of the DLL in the SysWOW64 folder. Hence the following command: copy %windir%\SysWOW64\msvcr100.dll %windir%\System32\msvcr100.dll
    Friday, March 12, 2010 8:29 AM
  • I am facing similar issue.

    I have VS Prof. 2010 RC running on my XP 32 bit, but I am building a Windows Service application for a x86-64 bit (Server 2008 x86-64) deployment. I am able to build for 64 bit, copy the binary over to Windows 2008.

    I installed the latest VS 2010 Shell (integrated) RC package on Server 2008 x64 system.

    My service, when I try to install fails with "cannot find MSVCR100.dll".

    I also saw that there is a copy of these in SYSWOW64 directory, but they don't work either.

    So I thought may be MS has not come around to properly releasing a clean redistributable package for 64 bit VS 2010. So I tried building this by installing VS 2008 prof. SP1 on my XP system. Now more woes - I don't even see the 64 bit platform in the configuration manager - so I can't even build for 64 bit from my XP 32 bit system?

    Any help?



    Wednesday, March 31, 2010 5:22 PM
  • Wow,


    For the most part I had all these errors:  MSVCR100.DLL AND the Document Explorer error and I had to cleanly uninstall vs 2010.  I had installed a lot of the components.... 


    Go in there and clean that sucker out!

    Friday, April 30, 2010 8:36 PM
  • Worked perfectly on my Win 7 Pro x64!!!  Thanks!
    Wednesday, July 21, 2010 4:40 AM
  • Here is what i did:

    When I looked in the System32 directory, I found a file named msvcr100_clr0400.dll. I simply made a copy of it and renamed it to msvcr100.dll. The file was placed in the system32 folder

    Tuesday, February 01, 2011 5:04 PM
  • This program can't start because MSVCR100.dll is missing from your computer? ... where is this dll normally found? and hhow can I get it again?
    Tuesday, April 05, 2011 1:53 PM
  • I managed to fix this missing MSVCR100.dll error by installing the 2010 C++ Visual Studio redistributable at:


    Thursday, May 05, 2011 7:58 PM
  • I managed to fix this missing MSVCR100.dll error by installing the 2010 C++ Visual Studio redistributable at:


    That's right, thank you, it works fine.


    Wednesday, May 25, 2011 2:19 PM
  • thanks a lot
    Tuesday, September 27, 2011 6:01 PM
  • Thank so much, for your time . I works for me . I happened when I tried to install Sql Developer in my laptop . A W7 home edition 64x.


    Saturday, November 05, 2011 4:21 AM
  • I had the same problem on a Windows XP machine after I removed a Visual Studio 2010 beta (not the release!).  VSCRT100.dll is apparently part of it.  Somehow its installation has caused the .NET framework to refer to it, even when running .NET 2.0 applications (created with Visual Studio 2005) or the Visual Studio 2005 installer.  (They should refer to VSCRT70.dll instead - that file was still present on my machine.)

    Installing .NET Framework 4 resolved the problem - but it's a bug of some sort, probably resolved in the VS 2010 release.

    Monday, November 14, 2011 5:14 PM
  • Ohh Thank u ... lol thats simple :) work for me :X


    Thursday, December 29, 2011 8:39 PM
  • I have seen  the  same proble the onl thing that i do was copy a dll file to the sysmte directory...
    Thursday, March 21, 2013 10:54 PM