Not loaded. A runtime error occurred during loading of COM add-in..


  • First of all, It drives me crazy.

    I'm using VS 2008sp1 to develop some excel add-ins for Excel 2007.

    When I run the apps by debugging, It works fine.
    But  deploying by Click-once to very same machine that I develop, It only shows me  " Not loaded. A runtime error occurred during loading of COM Add-in." .

    What's the problem?
    office 2007 PIA is installed manually again.
    .net framework v3.5 .. I don't feel need to check it.
    I tried  'VSTO_SUPPRESSDISPLAYALERTS', but I got nothing. just Not loaded.


    At first, when I deploy this add-in to other machine, it looks work fine. However, some of functions didn't work.
    I tried editing code, modify environment and etc,. about 4 hours for this ____. I eventually find the answer.

    When I deploy this apps.,  prerequisites was VSTO 3.0 not VSTO 3.0 sp1.
    Wow.. Actually when I start this project , I didn't even notice which version of  VSTO that I develop with.
    I think that  MS should change prerequisities to VSTO 3.0 sp1 when I install VS 2008 service pack1, doesn't it make sense?
    I develop under Sun, and distribute to ones under Stars,,, yeah.
    If someone have similar trouble, please check above thing.

    Wednesday, March 03, 2010 9:31 AM


All replies

  • I tried installation with click-once cd installation option, and it works very well...Add-ins finally work.

    Then where should I fix setting for  click-once network installation?

    I asked to clients to include server's ip in trusted site list. And I thought it is enough set to install, because it looks like installation works.

    Thursday, March 04, 2010 1:52 AM
  • Hello Freshful,

    Sorry for the confusion, but in my box I If I create a blank VSTO project, and goto publish page, check the "Prerequisites" dialog, I can see the item "Microsoft Visual Studio Tools for the Office system runtime service pack 1" is already been checked.

    If you need review the bootstrap settings, you could follow this article:

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by Tim Li Wednesday, March 10, 2010 10:25 AM
    Monday, March 08, 2010 9:54 AM
  • Hello Guys.


    I have searched a lot and implemented every ones solution but failed. I have upload my solution on this link. . this is Add-in for Word 2007 developed in VS 2010. Please check this. It works fine in development PC but setup dont work in other machine. gives errorr

    not loaded. A runtime error occurred during the loading of the COM add-in


    Thanks in Advance


    Wednesday, July 07, 2010 3:47 PM
  • Hi,


           Did you manage to solve above error. If so, please provide comments on that.




    Friday, September 03, 2010 9:23 AM