none
icon missing on toolbar in visual studio 2015 (VS 2015)

    Question

  • Hi all,

    I have just install vs 2015, but when I open it I am not getting the icon/image on any toolbars.

    I have tried to reset the toolbar, but it did not solve this problem.

    I tried to do a repair, but it did not solve this problem.

    I tried to uninstall then reinstall, but it did not solve this problem.

    All the Nvidia Driver are up-to-date. One of my colleague did the installation and it works fine for him. We have the same machine and we work on a corporate enviroment.

    If someone has an idea it would be nice.

    Here is a screenshoot : 

    Wednesday, August 05, 2015 8:14 AM

Answers

  • Hello Superfly35,

    There are two possible reasons for this issue:

    1. The icons haven't been installed to your OS due to corrupt installation

    2. Your Visual Studio does not have the permission to load those icons since I can see "enter Credentials"

    Do you have full control on your computer? Please try load VS by using this command:

    devenv /log https://msdn.microsoft.com/en-us/library/ms241272.aspx

    Send the Activity.xml log to somewhere for me to download or check. I think it will contain the info for we to check.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Superfly35 Monday, August 10, 2015 8:51 AM
    Thursday, August 06, 2015 3:17 AM
    Moderator

All replies

  • Hello Superfly35,

    There are two possible reasons for this issue:

    1. The icons haven't been installed to your OS due to corrupt installation

    2. Your Visual Studio does not have the permission to load those icons since I can see "enter Credentials"

    Do you have full control on your computer? Please try load VS by using this command:

    devenv /log https://msdn.microsoft.com/en-us/library/ms241272.aspx

    Send the Activity.xml log to somewhere for me to download or check. I think it will contain the info for we to check.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Superfly35 Monday, August 10, 2015 8:51 AM
    Thursday, August 06, 2015 3:17 AM
    Moderator
  • I have a similar problem. I had installed Visual Studio 2015 Community on Windows 7. After upgrading to Windows 10, I lost all my menu and toolbar icons. Running as administrator allows the icons to display, so for me it sounds like there is some permissions issue (go user access control!).

    Hope that helps.

    Sunday, August 09, 2015 12:01 PM
  • Following Barry's suggestion on admin right and/or issue on installation.

    My issue was profile related and I would right related too.

    My usual account which run VS2015 was not an admin account, I try to run it with an admin account and the account appear fine.

    I then redone the install onto another machine, with my usual account which was added as local admin on the machine for the purpose of the installation.

    The installation went fine no error, when run vs 2015 I still had no icon, but when run under another account also admin on the machine I could see the icon.

    We then decided to wipe my profile (I am in a corporate enviroment, where by the profile are centralised), after renaming my old profile, a new got created automatically and the icon appear on VS2015.

    I hope it will help other.

    Monday, August 10, 2015 8:57 AM
  • Hi,

    I don't believe this issue is caused by user permissions. VS shouldn't need admin rights to load images via the Image Service. I believe this issue is caused by a missing registry key. Check to see if "HKCU\Volatile Environment\LOCALAPPDATA” exists and contains a value similar to “C:\Users\<UserName>\AppData\Local". If that value doesn't exist, create it, and you should now be able to see images as a normal user and no longer need to launch as admin.

    Regards,

    Andrew

    Tuesday, August 25, 2015 5:31 PM
  • Hi all,

    I have just install vs 2015, but when I open it I am not getting the icon/image on any toolbars.

    I have tried to reset the toolbar, but it did not solve this problem.

    I tried to do a repair, but it did not solve this problem.

    I tried to uninstall then reinstall, but it did not solve this problem.

    <<SNIP>>
    I'm having the precise same issue as Superfly35. Unable to edit registry due to corporate policy. Any other suggestions?
    Wednesday, September 02, 2015 8:34 PM
  • Launch Visual Studio in safe mode (devenv /safemode).
    Icons should appear in toolbar from now.
    Sunday, September 20, 2015 1:00 PM
  • It doesn´t work for me. I can´t edit registry due to an error and launching Visual Studio in safe mode doesn`t solve the problem. 

    I could solve it creating the environmet variable LOCALAPPDATA following this steps:

    http://www.winhelponline.com/blog/add-localappdata-environment-variable-in-windows-xp/

    Reopen Visual Studio and icons appear

    Almudena


    • Edited by Almulf Tuesday, September 22, 2015 7:01 AM
    Tuesday, September 22, 2015 6:51 AM
  • I have the same issue:

    When I installed VS2015, icons were ok, so the instalation was not corrupted.

    Icons always disapears when I install or uninstall an extension (I have tried it with Productivity Power Tools, Resharper, JustCode, and couple of other smaller extensions)

    After couple of restarts icons usually appears again. I have also tried to play with Tools->Options->General->Automatically adjust visual experience base on client performance, but at some point, icons were visible regardles of this setting

    Running visual studio in administrator mode does not have any effect.

    here is my activitylog.xml

    EDIT:

    I've upgraded from win8 to win10 with files and settings kept but programs removed. Installed nothing but office2016 and visual studio 2015 (default instalation). At the first run icons were there, but when I tried to create new project from windows universal template I had to install the tooling first, because by default it was not installed. The icons disappeared.

    What helped me was to remove C:\Users\yourUserName\AppData\Local\iconcache.db


    • Edited by Daniel Turan Thursday, October 15, 2015 7:47 AM
    • Proposed as answer by xaprogrammer Sunday, December 25, 2016 7:06 PM
    Wednesday, October 14, 2015 12:30 PM
  • I have the same issue on Windows 7 after installing VS 2015.

    I tried image/svg+xml  suggested here.

    https://code.visualstudio.com/Docs/supporting/FAQ

    And repaired Visual Studio too to no avail.

    Really frustrating. 
    It would be really helpful if someone can help on this.


    Monday, October 26, 2015 11:27 AM
  • Microsoft released a FIX: Images are missing in Visual Studio 2015 that you can download and install. This software update will also be included in Update 1 for Microsoft Visual Studio 2015.

    Sergey Vlasov | Vlasov Studio | Visual Studio add-ins, extensions and tools

    Tuesday, October 27, 2015 3:22 AM
  • Running VS as administrator fixed my issue and now I can see the icons.
    Monday, November 09, 2015 5:16 PM
  • Hi Barry,

    I'm seeing the same issue. VS 2015 Enterprise on a clean install of Windows 10. Dell Optiplex i7 w/24GB.  ..will try the registry hack below, but hoping a patch will be issued soon? 

    Tks.,

    Chris

    Friday, January 08, 2016 10:17 PM
  • nope. MS REALLY needs to patch this, considering the amount of $$ they're charging.
    Saturday, January 09, 2016 7:52 AM
  • Tried the registry hack. - No luck.
    Saturday, January 09, 2016 7:53 AM
  • I had a similar issue with VS 2015.
    and lucky it's resolved by new update.
    https://support.microsoft.com/en-us/kb/3095681

    you try it.

    Wednesday, December 07, 2016 7:18 AM
  • Thanks.. this new update is working. I got those icons back. Thanks again :-)

    Tuesday, April 11, 2017 10:37 AM
  • Hi,

    In my case (VS2015), I have just deleted this file : C:\Users\<UserName>\AppData\Local\Microsoft\VisualStudio\14.0\ImageLibrary\ImageLibrary.cache

    Regards.

    • Proposed as answer by ojorma Tuesday, October 24, 2017 9:05 AM
    Thursday, August 31, 2017 10:07 AM
  • Thanks, deleting the file worked for me as well.
    Thursday, September 14, 2017 8:15 PM
  • thanks, this worked for me

    web developer

    Tuesday, October 24, 2017 9:05 AM
  • I confirm, deleting ImageLibrary.cache worked for me on the newest VisualStudio Community 2017 (15.4.4). 

    Of couse, in my case the cache file was in: AppData\Local\Microsoft\VisualStudio\15.0_6cf0401a\ImageLibrary

    (also: running Experimental instance had toolbar icons, but now I understand why: it creates its own folder in the AppData)
    Sunday, November 19, 2017 10:31 PM