none
Visual Studio shows permmission problem RRS feed

  • Question

  • When I try to make new project Visual Studio 2012 shows me a message " Visual Studio does not have permissions to read the template information from the system registry. This often caused by registry permmission problems."   

    Tell me how to deal with it. Because I didn't find solution on Internet.

    Thank You

    • Moved by Caillen Monday, August 12, 2013 2:03 AM
    Saturday, August 10, 2013 5:20 PM

Answers

All replies

  • Most likely, you have installed VS on Vista, Win 7 or Win 8 and UAC is enabled. Therefore you must enable the "run as administrator" on VS's shortcut,  or you go to the exe for VS and enable the property there to have the necessary rights.
    Saturday, August 10, 2013 5:31 PM
  • Hello bgdopus,

    Welcome to the MSDN forum.

    I have some related threads before so please refer to some workarounds there:

    1. http://social.msdn.microsoft.com/Forums/vstudio/en-US/d9bf6b02-2e49-44c4-8cdc-9a7857e99cc7/visual-studio-2102-will-not-start-a-new-project-of-any-kind

    2. http://social.msdn.microsoft.com/Forums/vstudio/en-US/dfa2df98-eecf-40a3-bbc0-7a6821020f00/unable-to-start-any-new-project-from-a-fresh-install-of-visual-studio-2012

    First of all, please try the following:

    "You can try script on this link: http://blogs.msdn.com/b/astebner/archive/2006/09/04/739820.aspx

    Its almost same script with one more line and output error for further checking.

    Also try to repair your VS 2012 installation and install all updates.

    Or try it manually to give permission:

    Start regedit
    right click HKEY_CLASSES_ROOT -> Permissions
    Click Add...
    Click Advanced...
    Click Find Now
    Select "Users" and Click "OK"
    Again "OK"
    Give Users "Full Control"
    Click "OK",  this can take a while

    Reboot your computer."

    Regards,


    Barry Wang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, August 12, 2013 2:05 AM
    Moderator
  • This issue has nothing to do with permissions in the context discussed. The issue is caused by an incorrect path to the template files in the registry due to sloppy installation program testing by MS. The incorrect path throws an error when a user tries to start a new project and, true to MS style, displays a generic and meaningless error message about permissions. Here's the issue specifically. In some machines (assuming c: is the primary drive and user1 is the user's login name and version 2013) the location of the template files is C:\users\user1\my documents\visual studio 2013\projects. Unfortunately the installation path written by the installer in the registry is C:\users\user1\documents\visual studio 2013\projects. So, it's pointing to \documents while the correct location is \my documents. To be sure, look where your visual studio 2013\projects folder is located - either documents or my documents - and change the registry key to the correct location. For my example the key is at HKEY_CURRENT_USER\software\Microsoft\VisualStudio\12.0\NewProjectDialog\MRUSettingsLocalProjectLocationEntries the path is located in the Value0 entry. Check it and change to make it point to exactly where your project folder is.
    Sunday, November 16, 2014 8:33 PM
  • You are going to come in here and post this nonsense 5 months later? :)
    Sunday, November 16, 2014 8:42 PM
  • My bad, that's over a year later! :)
    Sunday, November 16, 2014 8:44 PM
  • Boy you certainly do have a really large number of points - you must truly be knowledgeable in all aspects of VS. Wow, we are all really lucky to have you monitoring this forum to make sure new users understand your position and importance. What was I thinking coming in here a year after and trying to share the real cause of this issue?

    Man, I certainly do apologize for overstepping my place. I hope you can forgive me. Next time I'll be sure to run things like this past you first. In the meantime,  I'll try harder to post a lot of stuff for posting sake to build points in order to gain your respect and validation.

    Monday, November 17, 2014 2:10 PM
  • Oops, my bad - your solution didn't work! :(
    Monday, November 17, 2014 2:43 PM
  • Hey "KStj" THANK YOU!!!!!

    I've been trying to figure out why this was happening for the last two days. I was ready to scrap this and look for something else. I've tried all of the stuff dealing with the permissions and nothing worked. Your help was fantastic - I had the same issue with the path. It was a simple fix and now I CAN FINALLY USE VISUAL STUDIO!!

    By the way, I totally agree with what you said about that guy. It seems like some people are so impressed with themselves they figure they know everything. I just joined this forum trying to find a solution and also tried his which was a total waste of time like all the others. Thanks again for posting long after the original one. It doesn't matter when you do it as long as it helps somebody and it sure did for me. THANKS again!!

    Monday, November 17, 2014 3:39 PM
  • Man, I certainly do apologize for overstepping my place

    Your pacifer and Pampers are that ---------->

    Monday, November 17, 2014 3:47 PM
  • Oops, my bad - your solution didn't work! :(

    You were lucky to even trun on a computer!

    Monday, November 17, 2014 3:48 PM
  • By the way, I totally agree with what you said about that guy. It seems like some people are so impressed with themselves they figure they know everything.

    That's a bunch of BS. I didn't like his lipservice about MS and MS that. If he got to whine, then don't use the product.

    Monday, November 17, 2014 3:50 PM
  • Geeze guy - lighten up. I happen to like MS products but I have to agree with him. They were no help at all solving my issue and neither were the posts in this forum. It's tough to decide if you want to use a product if you can't get it to function. I checked out what he said and sure enough, the key was incorrect. All I had to do was change it to the correct path and now I'm up and running. Like I said I spent two frustrating days trying to get this app running.

    Now-don't take this the wrong way and blast out at me but, I run all my programs as administrator so your solution didn't work and his did. Again, take a deep breath, I appreciate you're trying at least but you don't have to be so aggressive.

    Opening up free use of VS is the best thing MS could ever do but, if you can't use it it's a moot point.

    Monday, November 17, 2014 5:02 PM
  • Geeze guy - lighten up.

    No, I am not. Anyone who came in here a starts mouthing off about MS that and MS this like he did has got the smell of baby oil, talcum powder and Linux about him.

    You come in,  address the isssue and move on, and there was no need for the rest of his dime and dozen lip-service.

    Monday, November 17, 2014 5:14 PM
  • Now-don't take this the wrong way and blast out at me but

    Oh by the way, tell me that you didn't sit there for over a year and did nothing about the issue you were having.

    Monday, November 17, 2014 5:17 PM