none
Issues deploying DNN and Orchard CMS on App Service v1.5 RRS feed

  • Question

  • Hello,

    I am running Azure Stack build 1902 with App Service v1.5 configured for high availability using the appservice-fileserver-sqlserver-ha QuickStart template and instructions in the Azure Stack Operator Documentation.  I am also running the SQL RP version 1.1.33.0. 


    Everything has appeared to function normally until I attempted to deploy the DNN and Orchard CMS marketplace gallery items into a user subscription.  I have verified that I can create databases for both these applications using the SQL Database marketplace gallery item.  The test access to the databases step is successful when attempting to deploy each of the Web Apps.  The respective Web Apps' resource objects get created, but I receive an error with both apps during the MSDeploy stage of the deployment.  At first, I see the MSDeploy step for Microsoft.Web/sites/Extensions throws a "GatewayTimeout" status with a message that reads "The gateway did not receive a response from Microsoft.Web within the specified time period."  Then, the final status when the provisioning state turns to 'Failed' is 'Conflict' with a message that simple reads 'code: "BadRequest"'.


    All my roles in the App Service Admin blade show that they are ready, and I confirmed the same via the Web Cloud Management MMC on one of the App Service Controller VMs.  I can create App Service Plans and deploy Web Apps that do not require a database without any problem.

    I would greatly appreciate any guidance you may be able to provide for troubleshooting this issue.

    Thanks,

    Mike

    Tuesday, April 9, 2019 9:29 PM

All replies