none
MS SoapToolKit 3.0 - SoapClient30 Client calling a WCF server

    Question

  • I get a Run-Time error '5415' when I call a WCF service from VB 6.0 with the MS Soap Toolkit 3.0

    Error : connector: connection time out. HRESULT=0x800A1527 Client: Sending the Soap message failed or no recognizable response was received.  Unspecified client error.

     Const WS_URL = "http://10.3.10.7:860/WS/?wsdl"

    Dim oWS As SoapClient30

    Set oWS = New SoapClient30

    oWS.MSSoapInit (WS_URL)

    strResp = oWS.Hello("VB", "Password")

     

    I tested the same code on the same server with a ASMX file hosted by IIS,

    and the code an method worked without issue.

     

    Do I have to set some attributes on the Operation Contract or Service Contract to allow for the MS Soap Toolkit 3.0 client to interop with a WCF service?

     

    I'm sure the url line is correct, because I can browse to it from IE on the same machine, and if I change the url to a invalid one, I get a different error.

     Also it is not a timeout issue, the error comes back right away, but just to try it, I changed the connection timeout to 90000, and I got the same error listed above.

    Thursday, May 25, 2006 6:33 PM

Answers

  • Thanks Madhu,

    I go my app to work with the following.

    'System test result boolean
    Dim bResult As Boolean

    ' MS SoapToolkit 3.0 objects
    ' http://www.microsoft.com/downloads/details.aspx?familyid=c943c0dd-ceec-4088-9753-86f052ec8450&displaylang=en
      Dim oPPWS As SoapClient30
      Set oPPWS = New SoapClient30

      ' qa url for testing
      Const URL = "https://[serverip/name]/?wsdl"

      ' get the wsdl file
      oPPWS.MSSoapInit URL

      ' call Hello which returns a string.
      strResp = oWS.Hello("VB", "Password")

      ' call System test which returns a bool
      bResult = oWS.SystemTest()

      MsgBox ("oWS.Hello[" + strResp + "] oWS.SystemTest[" + CStr(bResult) + "]")

    End Sub


    I had two issues:
    1) When you selfhost the app there is no .svc for the url line,
    it should be /?wsdl, I had that worked out before I posted my question.

    2.) My test app is an NT service and for some reason it was not generating the wsdl
    correctly, I think I had WSHttpBinding at one point then I switched to BasicHttpBinding
    but the wsdl did not seem to change.  One way to tell is in the port section of the wsdl, and
    if you see soap12 tags in the wsdl you don't have BasicHttpBinding.

    Friday, May 26, 2006 5:15 PM

All replies