none
Missing Registration For Location or re-register provider for this location

    Question

  • When I try to publish an app within Microsoft Visual Studio I get an error telling me that:

    Error during deployment for resouces 'my app name' in resource group 'my resource group name': MissingRegistrationForLocation: The Subscription is not registered for the resource type 'components' in the location 'Central US'. Please re-register for this provider in order to have access to this location...

    I am not finding any solutions from Microsoft Azure. How can I fix this so I can continue to publish new and exiting apps?

    Thanks for the help.

    Thursday, December 08, 2016 10:03 PM

Answers

All replies

  • Greetings!

    Thank you for posting here!

    Does this only happen when you attempt to deploy WebApp via Visual Studio? Have you tested to see if it works fine when deploying the WebApp via the Azure Portal?

    Kindly update your Visual Studio and ensure that you are using the latest version of Azure SDK.

    Navigate to (https://manage.windowsazure.com) or (https://portal.azure.com) with your active subscription and then try to create a test WebApp using the Azure portal (without using VS).

    Reference : There is a discussion on similar issue here please check that as well.

    Hope this helps!  

    Regards,
    Ajay

    ---------------------------------------------------------------------------------------------------

    Kindly click "Mark as Answer" on the post that helps you, this can be beneficial to other community members reading the thread and ‘Vote as Helpful’

    Friday, December 09, 2016 8:02 AM
    Moderator
  • Hi,

    I got the same error.

    Follow this link. 

    https://docs.microsoft.com/en-us/azure/azure-resource-manager/resource-manager-supported-services#resource-providers-and-types

    You will be able to solve the issue

    Sunday, December 25, 2016 10:27 AM
  • I am having the same error.

    I did follow the link and I registered the Microsoft.OperationalInsights resource provider. I did this because I seem to remember that somewhere on the Azure portal it said that there was a "conflict" during deployment regarding OperationalInsight. I'd like to revisit that part of the portal but I cannot find it anymore.

    Apart form that, which are the necessary recource providers that need to be registered for an MVC website (a base one that you get when creating a new MVC project in VS2015)?  

    kind regards,

    Hans

    Thursday, December 29, 2016 6:29 PM
  • Hi,

    Did we got this issue resloved?  I am facing same issue. I am using Vs2015 and Azure SDK 2.0

    Thanks in advance

    Sri C

    Thursday, January 19, 2017 10:44 PM
  • Hello Sri,

    Upgrading Azure SDK to 2.9.6 version fixed this issue for me,

    Kind Regards,

    Nazim


    Thursday, February 02, 2017 11:50 AM
  • Doesn't fix for me, have updated all Nuget packages. Can someone help? I cant publish a simple webapp on Azure and am totally blocked:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    Following errors occured during the deployment:
    Error during deployment for resource 'agihitapp' in resource group 'agihitapprg': MissingRegistrationForLocation: The subscription is not registered for the resource type 'components' in the location 'Central US'. Please re-register for this provider in order to have access to this location..

    ---------------------------
    OK  
    ---------------------------

    Above is the exact error I get from VS in trying to publish. I'm trying to trying to webapp which is running fine on local box. I also tried a new project route and it gives the same error. I checked the subscription and it is registered for "Microsoft.Web" and clicking on "re-register" doesn't do anything.

    Any help would be great!

    Saturday, February 25, 2017 7:38 AM
  • Hi,

    I got the same problem, and what I did is:

    1. Installed Microsoft Azure SDK for .NET for VS2015 as I am using this currently, you can install any other like for VS2017 or lower versions as well through Web Platform Installer.

    2. then try to publish the web app.

    for me it worked fine after this.

    Hope this has helped. thanks!

    Thursday, March 09, 2017 7:14 AM
  • this work's for me. Publish manu on vs 2015 changed after install new azure sdk. Thanks.

    Hugo

    Saturday, March 11, 2017 3:52 PM
  • I had the same problem. Installing the latest Azure SDK also solved this for me. See https://www.visualstudio.com/vs/azure-tools/ for more info and download
    Friday, March 17, 2017 3:27 PM
  • Installing Azure SDK 2.9.6 for visual studio 2015 resolved this issue for me. The visual studio 2015 web app publish interface also changed after installing SDK. 

    Hope this helps someone.


    Kannan


    Sunday, April 23, 2017 1:23 PM
  • Glad to hear that the issue has been resolved after installing the updated/latest version of Azure SDK.

    Sunday, April 23, 2017 3:41 PM
    Moderator