none
TypeInitializationException when running app RRS feed

  • Question

  • Hi,

    Does anybody know what could be going on.  When I run my application from the Program Files shortcut that is added in the install the application runs fine.

    When I run from an shortcut that I have added to the Startup, it cannot find one of the assemblies.

    System.TypeInitializationException: The type initializer for "Maxess.Keyboard.Keys.SendKeys.KeyPress" threw an exception. ---> System.IO.FileNotFoundException: Could not find file "C:\Documents and Settings\Bronagh\Dynosaw.Application.Utils.Logging".
    File name: "C:\Documents and Settings\Bronagh\Dynosaw.Application.Utils.Logging"System.TypeInitializationException: The type initializer for "Maxess.Keyboard.Keys.SendKeys.KeyPress" threw an exception. ---> System.IO.FileNotFoundException: Could not find file "C:\Documents and Settings\Bronagh\Dynosaw.Application.Utils.Logging".
    File name: "C:\Documents and Settings\Bronagh\Dynosaw.Application.Utils.Logging"System.TypeInitializationException: The type initializer for "Maxess.Keyboard.Keys.SendKeys.KeyPress" threw an exception. ---> System.IO.FileNotFoundException: Could not find file "C:\Documents and Settings\Bronagh\Dynosaw.Application.Utils.Logging".
    File name: "C:\Documents and Settings\Bronagh\Dynosaw.Application.Utils.Logging"

    From what I see of the Exception it is looking for the assembly in the wrong location. 

    Does anybody know why?

    Sunday, October 8, 2006 2:25 PM

Answers

  • Right click on the shortcut, choose properties...verify that the Start In directory is the one you intend.
    Monday, October 9, 2006 4:35 AM
    Moderator