none
error highlighting not working

    Question

  • I am using Microsoft Visual C++ 2010 edition on Windows 7.

    I can't get syntax highlighting to work and I can't get the error list to display.

    For the syntax highlighting I have gone to Tools >> Options >> Text Editor >> C/C++ and taken a look at all the options. Under the advanced tab there are options relating to disabling IntelliSense features and these are all set to false.

    This doesn't appear to be the option. I know that I have syntax errors but I can't see where they are.

    Wednesday, December 17, 2014 9:10 PM

Answers

  • Hi fborok,

    Based on your issue, you mean that when you editor your c++ code in Microsoft Visual C++ 2010, you could not get the syntax errors highlighting squiggly line like the following screen shot, am I right?

    If yes, I suggest you can try to make sure the ‘Disable Squiggles’ is set to ‘False’ in Tools->Options->Text Editor->C/C++->Advanced.

    If the above way doesn’t work,  I suggest you can try to restart your VS as Admin and try to reset all your settings through Tools->Import and Export settings->Reset All Settings->.... to check if it can help.

    In addition, to make sure if you install some third-party Add-ins impact the syntax errors highlighting, I suggest you can run /safemode in Command Prompt check the issue again.

    Reference:

    http://msdn.microsoft.com/en-us/library/ms241278(v=vs.100).aspx

    If still no help, I suggest you try to repair your VS or reinstall it check this issue again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, December 18, 2014 7:30 AM
    Moderator

All replies

  • To see syntax errors, display the Output Window. If you don't see a tab labeled "Output" in the area below the editor window, display it by View->Output.

    Your syntax errors will be listed in the Output Window. If you double click on a syntax error message, the text editor will automatically scroll to the offending statement and outline it in a blue rectangle.

    Let us know if this works for you.

    Wednesday, December 17, 2014 9:29 PM
  • I've got that but what would be useful is the little squiggly line so I can see exactly where the problem is. Using the output window is such a slow work around.

    Thursday, December 18, 2014 1:15 AM
  • Hi fborok,

    Based on your issue, you mean that when you editor your c++ code in Microsoft Visual C++ 2010, you could not get the syntax errors highlighting squiggly line like the following screen shot, am I right?

    If yes, I suggest you can try to make sure the ‘Disable Squiggles’ is set to ‘False’ in Tools->Options->Text Editor->C/C++->Advanced.

    If the above way doesn’t work,  I suggest you can try to restart your VS as Admin and try to reset all your settings through Tools->Import and Export settings->Reset All Settings->.... to check if it can help.

    In addition, to make sure if you install some third-party Add-ins impact the syntax errors highlighting, I suggest you can run /safemode in Command Prompt check the issue again.

    Reference:

    http://msdn.microsoft.com/en-us/library/ms241278(v=vs.100).aspx

    If still no help, I suggest you try to repair your VS or reinstall it check this issue again.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, December 18, 2014 7:30 AM
    Moderator