none
Solution stuck loading and projects initializing RRS feed

  • Question

  • We had a third party company recently create a website for us and send over the solution
    which is in Visual Studio 2012. When I open the solution the first time,
    everything works as usual. However, after closing and reopening, it gets stuck
    on initializing all but one of the projects (see screen shot below).

    This is my first use of the 2012 software outside of a little tinkering I've done with it
    a few months ago. I have tried repairing the program and even uninstalling then
    reinstalling. I've also installed the recent Update 2, but the issue continues
    to happen. I'm just unable to open it after the first time.

    I checked with the company who created the solution, and of course they have no issues. I
    had one of my coworkers install VS2012 and he has no issues with it. So, any
    ideas what the issue is with my computer. I'm hoping there is a setting that I
    just have to adjust.

    I am running Visual Studio Professional 2012. Thanks in advance for any assistance.



    • Edited by clunger Friday, May 10, 2013 2:45 PM
    Friday, May 10, 2013 12:44 PM

All replies

  • Hi clunger,

    I suggest you restart your machine, and then re-open this solution again.

    To make sure that it is not the VS setting issue, I suggest you reset your VS settings.

    If there are many projects in the same solution, it will have this issue since it is loading all projects now like the following screen shot, but it will have no this issue after the loading finishes.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, May 13, 2013 6:05 AM
    Moderator
  • To be honest, I don't think this should be marked as the solution - it doesn't resolve the issue, at least not for me, and it doesn't explain the issue either.

    The issue I am seeing is where the My Documents drive is mapped to a network. IISExpress doesn't like this at all, and crashes, filling the IISExpress\config\applicationhost.config file with junk.

    If edited to correct the XML the solution then attempts to load and causes this crash. If the IISExpress\config\applicationhost.config file is made invalid then the solution loads, but without the web project.

    It looks to me like the problem is when My Documents is mapped to a network drive, and IISExpress is used within the solution.

    The solution that worked for me is to create a CustomUserHome property as described here:
    http://www.iis.net/learn/extensions/introduction-to-iis-express/iis-80-express-readme

    Hope this helps someone,

    Nick

    Tuesday, October 1, 2013 4:30 PM
  • I got same issue and was utterly frustrated with it. I noticed this file *.v12 Visual Studio Solution user Option file which is created by VS when we open this solution. I deleted this file and the solution opened perfectly. This file is created at the same folder as the solution file.

    Saturday, November 30, 2013 7:19 AM
  • Thanks for this, I was wasting some serious time with this problem and this fixed it right away!
    Thursday, February 13, 2014 7:46 PM
  • This worked perfectly for me as well.

    I could not find this anywhere else on the internet, so thank you for this.

    Wednesday, April 9, 2014 9:05 PM
  • this fixed the problem after upgrading from vs2012 to VS2015. THANK you.
    Tuesday, December 29, 2015 8:39 AM
  • Old item, I know, but I had the same issue in VS 2015 Update 1.  I resolved it by deleting the .vs folder in the solution folder.  It has to rebuild a few things, but I think the core of the issue (for me, at least) was a messed up metadata file in the .vs folder.
    Wednesday, February 24, 2016 2:53 PM
  • WOW! That was my problem as well! Saved me some serious time.
    Wednesday, March 2, 2016 3:32 PM
  • None of the other suggested solutions worked for me but this one. VS2015

    Tuesday, March 29, 2016 12:02 PM
  • This nailed it! Thanks
    Wednesday, May 4, 2016 7:28 PM
  • This resolved my issue. FYI - .vs is a hidden folder at the *.sln folder level. 
    Monday, August 29, 2016 12:59 PM
  • I also had to delete a hidden folder called .vs in the solution's folder.

    Thanks for the help!

    Tuesday, December 20, 2016 4:39 PM
  • works perfectly ! thanks!
    Monday, February 20, 2017 2:40 PM
  • I experience the same issue where a project loads forever.

    IIS8 was not a solution as my system had a newer version already installed. I did however move the source folder to another location on my PC hard drive and this solved the issue.

    The only thing I can think of and I'm probably spitting in the wind here could be due to a bad sector on my hard drive.This worked for me so might be just the thing that solves your issue.

    Thursday, November 16, 2017 4:16 PM
  • I am having the same problem on a laptop....but this is not an IISx problem -- I am getting it on WinForms projects where IIS is not even involved.

    I only have VS2015 Enterprise installed so I cannot speak to other versions of Visual Studio.

    Yes, deleting the .suo file in the .vs folder does fix the problem...once. But the next time I open the (any) project, the same problem occurs again.  It's vicious circle and the only solution is to delete the .suo file every time before I try to load the project/solution.

    I have tried totally building a new project by importing the components from the original project and that does not solve the problem either.  It continues to happen with the new project as well as the old.

    Deleting the .suo file is not a solution...it's nothing but a band-aid.  The actual problem is not fixed by it.

    Extremely frustrating and Microsoft's lack of a real fix is not acceptable.

    Wednesday, March 14, 2018 3:46 PM
  • It worked for me as well!!!!

    Many thanks

    Thursday, May 17, 2018 11:18 AM