none
TreeView not fully updated RRS feed

  • Question

  • Hi.. my treeview is binding to a datatable in a dataset. It uses this:

    <HierarchicalDataTemplate x:Key="RecursiveTemplate" ItemsSource="{Binding rel_tblLineaNegocio_tblSubLineaNegocio}">
    <TextBlock Text="{Binding Nombre}" Padding="4,0" />
    </HierarchicalDataTemplate>

    tviLineasNegocio.ItemsSource = Tables["tblLineaNegocio"].DefaultView;

    to display two tables joined by the relation "rel_tblLineaNegocio_tblSubLineaNegocio". When a new row is added to the child table, the treeview display is automatically updated. But, when modified the displayed field of the child table, the display of the treeview is not updated. Am I missing something?

    Thursday, August 28, 2008 9:32 PM

All replies

  • -> But, when modified the displayed field of the child table, the display of the treeview is not updated. Am I missing something?

    Could you please roll up a small, complete and ready-to-run example, and send to me at v-mazho at microsoft dot com for repro?

    Thanks
    Tuesday, September 2, 2008 9:09 AM
  • Hi Marco... I was "cutting" the application cause it is kind of big and you have to do some additional work to make it work. While trying to isolate the page showing the problem, found the isolated page (in a new project) did not suffer from my reported problem. What I did was copy and paste the page to another project and cut those parts as reference to other libraries, custom controls, etc.

    The solution is  4 class libraries, a web site, and an xbap application. A SqlServer database is also included.

    May I send you all this?

    Thank you.
    Tuesday, September 2, 2008 2:02 PM
  • Well, I would greatly appreciate it if you could repro this issue by creating simple project. In particularly, you could isolate the data access layer code by creating the fake DataSet/DataTable, and you also could isolate the problem by creating a simple WPF Windows application, because I believe this problem has nothing to do with WebSite project/XBAP application etc etc.

    There is some of the known issues with data binding against ADO.NET data, but without seeing this repro project, I cannot figure out which old issue/or even new issue you are encountering.

    Thanks
    Wednesday, September 3, 2008 3:40 AM