none
Intellisense not working on one project - VS2019 RRS feed

  • Question

  • Hello,

    I'm having issues with one specific project in VS2019. After upgrading from VS2017, I got the solution from the TFS.

    Everything was working fine until I modified a file of this project. Intellisense stopped working.

    It should be something related to this project file because if I modify other files in other projects from the same solution it keeps working fine.

    What can I do to try to fix it?


    Hugo

    Wednesday, April 17, 2019 7:30 PM

All replies

  • Hi hsrm,

    Welcome to the MSDN forum,

    Everything was working fine until I modified a file of this project. Intellisense stopped working.” What and how did file you modify? Could share us the specific steps and info? Did you try to rebuild your project after modifying done?

    I am guessing, Intellisense doesn't know what to do or recognize this file, please unload and reload it.

    If not, please have a try with the following steps to clean caches of your project:

    1. View => Solution Explorer (in case it isn't already open)
    2. Right click "Solution 'Project name'"
    3. Click "Open Folder in File Explorer"
    4. Close Visual Studio
    5. Show hidden folders (Win10 How-to)
    6. Delete folder ".vs"
    7. Open Visual Studio and project (wait a few seconds)

    Sincerely

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Proposed as answer by NiclasSparr Friday, August 30, 2019 7:28 AM
    Thursday, April 18, 2019 6:16 AM
    Moderator
  • Hi friend,

    Is there any update for your issue?

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, April 19, 2019 6:26 AM
    Moderator
  • Hi, 

    had the same problem. this solution worked for me.

    /Niclas

    • Proposed as answer by Alex Hardwicke Tuesday, September 17, 2019 6:48 PM
    Friday, August 30, 2019 7:28 AM
  • Hi,

    A quick trick that seems to "wake Intellisense back up" for me is to click on Project->Show All Files. For some reason VS occasionally drops all of the external dependencies. Clicking "Show All Files" brings them back.

    Hope this helps,

    Thomas

    Wednesday, September 4, 2019 8:37 PM
  • This last suggestion ( Project -> Show All Files ) worked for me.
    Monday, December 2, 2019 11:29 PM
  • My colleague's problem was that the version of .NET framework in the project being referenced was higher than the project referencing it.
    Wednesday, January 8, 2020 11:33 PM