Error received while Validating the Archtiecture of my Layer Diagram


  • When validating my solution against the Layer Diagram I get the following error.

    TextSpans property not found at VbProvider.Initialize(IServiceProvider serviceProvider) at MiniVSIXProviderData.ActivateProvider(IServiceProvider serviceProvider) at DirectoryProviderLoader.InitializeProviders(IProviderData{} providersToActivate) at GraphCmdLibrary.Initialize() at GraphCmdLibrary.Execute() at GraphCmdLibraryCmd.Run(String[] args) at Program.Main(String[] args)

    I get the same error when tryign to generate dependencies.  I am using VS 2010 Ultimate SP1 and received the error weather Feature Pack 2 was installed or not.  Running GraphCmd.exe outside of VS 2010 also causes the error.  If I select Retry it opens VS 2010 as a debugger and after doing that at least once for every project in the solution it will generate the dependencies and validate the architecture.

    • Edited by John Reg Wednesday, January 23, 2013 12:51 PM Additional Information
    Tuesday, January 22, 2013 5:45 PM

All replies

  • I'm seeing the exact same error.  Hopefully someone can offer up a solution or work-around as the assertion dialog is modal and disrupts my command line builds.
    Tuesday, April 16, 2013 9:01 PM