none
How to change which browser is started for in-browser desktop client? RRS feed

  • Question

  • After switching the desktop client to run in-browser, it currently starts in my default browser (Chrome) - how can I get it to start in IE instead, but without changing my user's registered default browser?

    Thanks!

    Wednesday, May 8, 2013 6:45 PM

Answers

  • In your LightSwitch project, toggle to File View, scroll down to the Server node and right-click on the Web folder and select "Browse with..."  Set as default any of the installed web browsers on your system and click cancel. F5 should now open the project with that browser.
    Friday, May 10, 2013 5:32 AM

All replies

  • Hi,

    LIGHTSWITCH does not expose this settings, but I believe LIGHTSWITCH shares the same Debugger Browser setting with Web Project. You can try:

    • Create an Empty Web ASPX Project.
    • The Debug command should show the Browser as Chrome. Switch to IE.
    • Open LIGHTSWITCH project again.
    • I've read from a different thread this setting can be lost sometimes, but can be restored the same way.

    Best regards,
    Huy

    Thursday, May 9, 2013 8:54 PM
  • In your LightSwitch project, toggle to File View, scroll down to the Server node and right-click on the Web folder and select "Browse with..."  Set as default any of the installed web browsers on your system and click cancel. F5 should now open the project with that browser.
    Friday, May 10, 2013 5:32 AM
  • There is no "File View" in LS 2013. And even if one right-clicks the default.aspx file in the Server component, there is no "Browwse with..." item.
    Wednesday, October 29, 2014 4:18 PM
  • this is the only correct method for Lightswitch projects. Trying to remember this gets me every time....
    Tuesday, May 9, 2017 9:35 AM