HELP! CodeAnalysis task... RRS feed

  • Question

  • Since I installed VS2008 SP1, I now get an error when trying to compile my program.  The error says "Invalid settings passed to CodeAnalysis task.  See output window for details."  Here's what the Output window shows...

    Running Code Analysis...
    C:\Program Files\Microsoft FxCop 1.36\FxCopCmd.exe  /outputCulture:1033 /out:"bin\Release\Spheris.Common.dll.CodeAnalysisLog.xml" /file:"bin\Release\Spheris.Common.dll" /directory:"C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727" /directory:"C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5" /rule:"C:\Program Files\Microsoft FxCop 1.36\Rules" /ruleid:-Microsoft.Globalization#CA1301 /ruleid:-Microsoft.Globalization#CA1302 /ruleid:-Microsoft.Globalization#CA1303 /ruleid:-Microsoft.Globalization#CA1306 /ruleid:-Microsoft.Globalization#CA1304 /ruleid:-Microsoft.Globalization#CA1305 /ruleid:-Microsoft.Globalization#CA1300 /searchgac /ignoreinvalidtargets /forceoutput /successfile /ignoregeneratedcode /saveMessagesToReport:Active /targetframeworkversion:v3.5 /timeout:120
    MSBUILD : error : Invalid settings passed to CodeAnalysis task. See output window for details.

    If I look in the project properties, there is a conditional compilation symbol of "CODE_ANALYSIS".  I think this is a leftover from when the project was started under VS2005 TFS.  I can't seem to get rid of this symbol.  If I delete the text and save the file, it appears to be gone but when I re-open VS it comes right back.  It was there before but never caused a problem before I installed SP1.  Weird thing is that in debug mode, I get this when I first hit F5.  If I hit F5 again without changing anything, the program runs w/o error.  So, I've been ignoring it until now...when it's time to deploy. :(

    Any help would be greatly appreciated.



    Sunday, August 24, 2008 10:44 PM


  • Uninstalling FxCop seems to have solved the problem.  I'll try re-installing FxCop tomorrow and see if I'm still able to compile.

    Sunday, August 24, 2008 10:54 PM

All replies