none
error when dragging data source object to designer RRS feed

  • Question

  • hi

    i got this error message when i try to drag EF object from Data source panel to grid in designer.

    create new project , save it , add ADO model to it , create couple entities , save , build , add new data source for the

    created entities ,try ti drag the object to designer , error message appear .

    when i close VS and reopen it again , this error gos away and i can drag and drop , can anyone produce this ?

    I'm using vs 2013 on windows 8.1

    best regards

    hani

    Monday, January 6, 2014 7:18 PM

Answers

  • Hi,

    I consulted WPF engineer and repro your scenario, we can get the same result with you. We also doubt it is an issue. You can submit this feedback to Microsoft Connect feedback portal as you said: http://connect.microsoft.com, Microsoft engineers will evaluate them seriously.

    After you submit the feedback, you can post the link here which will be beneficial for other members with the similar issue. And I will help you to vote it.

    Bets regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Hani Safa Wednesday, January 8, 2014 7:10 PM
    Wednesday, January 8, 2014 3:01 AM
    Moderator

All replies

  • Hi,

    I am not Entity Framework experts so it is hard for me to repro this issue.

    Because you said you can drag and drop after you restart VS, I doubt that the issue may be related to your VS environment. If you have other machines, you also can research this issue on another machine.

    I did some search and find some threads with similar issue. Hope they can help you.

    Please make sure the project was created in the local drive(where VS was installed), reference:

    http://social.msdn.microsoft.com/Forums/en-US/9fc4f835-d6c0-4d04-86c2-779c1f8e0791/unable-to-drag-data-source-to-control-to-bind

    Try to enable ‘Load per user extensions when running as administrator’ in Tools->Options->Extension and Updates, reference:

    http://social.msdn.microsoft.com/Forums/en-US/32c3dd42-fa00-4218-bb78-d6f1bbbe86dd/unable-to-drag-data-source-onto-designer-to-bind-it?forum=vswpfdesigner

    After that, please clean your project and rebuild it to check the result.

    If no help, please repair or reinstall your VS.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, January 7, 2014 6:00 AM
    Moderator
  • thanks for your help ,

    i did some testing and found this:

    its not EF thing , create new project , save it , add new class to it , build , add this class as a data source

    try to drag it to designer same error .

    EF 5,6 generate POCO classes anyway.

    regarding the first link , i saved 2 projects on my local hard driver , one on desktop and one on e driver , same error.

    regarding the second link , the option is enabled by default in vs 2013

    and i test it on another PC the same thing happened

    could you confirm that this happened with you ? if so , I'll reported it as a bug

    best regards

    hani


    • Edited by Hani Safa Tuesday, January 7, 2014 10:26 PM
    Tuesday, January 7, 2014 10:25 PM
  • Hi,

    I consulted WPF engineer and repro your scenario, we can get the same result with you. We also doubt it is an issue. You can submit this feedback to Microsoft Connect feedback portal as you said: http://connect.microsoft.com, Microsoft engineers will evaluate them seriously.

    After you submit the feedback, you can post the link here which will be beneficial for other members with the similar issue. And I will help you to vote it.

    Bets regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Hani Safa Wednesday, January 8, 2014 7:10 PM
    Wednesday, January 8, 2014 3:01 AM
    Moderator
  • thanks for your time,

    you are right it's not an issue , but its a bug and i love VS very much, i want it supper :)

    I've report it her

    best regards

    hani

    Wednesday, January 8, 2014 7:10 PM
  • Hi Hani,

    Voted it.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 9, 2014 1:36 AM
    Moderator