none
ASDK 1902 Deployment is failing | Invocation of step 0.PhysicalMachineAndInitialConfiguration failed RRS feed

  • Question

  • Hello Team,

    Please, I need your help with the following error.

    I am deploying ASDK on the same hardware what I used to deploy previous ASDK releases. The ASDK 1902 is failing at the preliminary steps as shown in the screenshot below.

    Could you please advise? 

    Thank You!

    -Charbel

    Wednesday, March 13, 2019 9:08 PM

Answers

  • @chrisblackgb87

    This is a known issue with 1902, and we are working to get a fix & better workaround out. 

    The current workaround:

    Open up the file at C:\CloudDeployment\Roles\PhysicalMachines\Tests\BareMetal.Tests.ps1 in any editor with a line counter on it. PowerShell ISE worked for me.

     

    Delete the “Memory Information” test, which is from lines 609 to 780, or delete everything from:

     


            #

            # Start: Memory information

            #

     

    To

             #

            # Start: SCSI Adapter information

            #

     

    If you try this, please let me know if it works for you!


    Friday, April 5, 2019 5:50 PM
    Moderator

All replies

  • Hello Charbel, 

    Unfortunately, the error you are getting does not give us much to go on, but it does seem to be happening fairly early in the deployment. 

    Even though you have deployed the ASDK on that machine before, I would like to go back and double check that the computer is ready for an Azure stack Deployment. 

    First, verify that your machine meets the minimum hardware requirements, and that your disks are in the proper configuration (this is unlikely, as it has not changed with this version)

    Next, run the Deployment Checker for Azure Stack Development Kit to make sure there are no issues with your current configuration. 

    A similar error has occured before, but it looks like it was fixed with a redeploy. Try to update your base machine's Windows OS and drivers, make sure to delete the cloudbuilder.vhdx, and try the deployment again. If it fails, let me know and we will gather deployment logs to find the exact cause of the failure. 

    Thursday, March 14, 2019 9:32 PM
    Moderator
  • Hello Travis,

    Thank you for your respond.

    Unfortunately, the installation is not going through. I have re-downloaded the bits, updated the firmware/drives and still failing at retrieving the network adapter information. I am using only one NIC, all the remaining NICs are disabled.

    I have also validated/prechecked the host with asdk-prechecker.ps1 and all looks ok and green. Your help is highly appreciated!

    Please advise?

    Thank You!

    -Charbel

    Friday, March 15, 2019 12:46 PM
  • Hey Charbel,

    What happens when you use the "InstallAzureStackPOC.ps1 -Rerun" switch in a new PowerShell window.

    I encounter this behavior sometimes when I had already a PowerShell window open connected to a remote share.

    Eelco

    Thursday, March 28, 2019 6:23 AM
  • Thank You Eelco,

    I have tried that switch in a new PowerShell window but the issue remains the same.

    Microsoft found out that there is a bug in 1902.

    This appears to be an issue with getting Network Adapter information. They are currently following up with our deployment team to see why this happened, and a way that they can mitigate.

    Thanks!

    -Charbel

    Thursday, March 28, 2019 9:46 AM
  • Did you ever manage to get it fixed as I am having all sorts of issues with Network Adapter info ;-(
    Friday, April 5, 2019 3:03 PM
  • @chrisblackgb87

    This is a known issue with 1902, and we are working to get a fix & better workaround out. 

    The current workaround:

    Open up the file at C:\CloudDeployment\Roles\PhysicalMachines\Tests\BareMetal.Tests.ps1 in any editor with a line counter on it. PowerShell ISE worked for me.

     

    Delete the “Memory Information” test, which is from lines 609 to 780, or delete everything from:

     


            #

            # Start: Memory information

            #

     

    To

             #

            # Start: SCSI Adapter information

            #

     

    If you try this, please let me know if it works for you!


    Friday, April 5, 2019 5:50 PM
    Moderator
  • Thank you Travis!

    The issue is resolved now by following the steps mentioned above.

    Cheers,

    -Charbel

    Saturday, April 6, 2019 7:22 PM
  • FYI This issue still persists on 1904, only accompanied with a few more errors. The mitigation above also still works for 1904 as well. 
    Friday, May 10, 2019 1:14 AM
    Moderator
  • Thank You Travis for the confirmation!
    Friday, May 10, 2019 5:54 AM