none
My firewall application does not work on windows 10 but works on windows 7 RRS feed

  • Question

  • My firewall application developed on Home PC with windows 7 using visual studio 2012 works correctly on PC.   But when I try to run it on laptop with Windows 10, also using visual studio 2012,  it does not work correctly. There are not any errors in output window, but on the form itself, when I press firewall start button, it does not work. Packets cannot be filtered. In textbox, there must be message "firewall running". But instead of this , it shows the message "error!".  I cannot understand why exact the same code don't work on windows 10 and works on windows 7??  Why windows filtering platform functions don't work on windows 10? ((   And I also want to add that when I installed visual studio 2012 russian on my laptop, firewall worked properly. Then I installed english language pack for convenience. After that my firewall stopped working. I don't understand why it happened?? why so innocent language pack destroyed the work of my firewall ? ((   I also reinstalled visual studio 2012, created empty project from scratch but it didn't help.    Please help me, I very need your help! How to solve this problem?  I am very tired.  Thank you in advance. 
    Tuesday, March 22, 2016 8:59 AM

All replies

  • My firewall application developed on Home PC with windows 7 using visual studio 2012 works correctly on PC.   But when I try to run it on laptop with Windows 10, also using visual studio 2012,  it does not work correctly. There are not any errors in output window, but on the form itself, when I press firewall start button, it does not work. Packets cannot be filtered. In textbox, there must be message "firewall running". But instead of this , it shows the message "error!".  I cannot understand why exact the same code don't work on windows 10 and works on windows 7??  Why windows filtering platform functions don't work on windows 10? ((   And I also want to add that when I installed visual studio 2012 russian on my laptop, firewall worked properly. Then I installed english language pack for convenience. After that my firewall stopped working. I don't understand why it happened?? why so innocent language pack destroyed the work of my firewall ? ((   I also reinstalled visual studio 2012, created empty project from scratch but it didn't help.    Please help me, I very need your help! How to solve this problem?  I am very tired.  Thank you in advance. 

    I can send you the code or the screens, anything, but I'm waiting for your help only.
    Tuesday, March 22, 2016 9:01 AM
  • Hi Seidkhan,

    This forum is discussing and asking questions about issues regarding the very core of .NET. Based on your description, your case more related to windows OS Compatibility. I am afraid this is out of our forum support scope.

    In addition, I would suggest you try to debug on win10 machine, and try to find the difference between win 7 and win10.

    Best regards,

    Kristin 


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, March 23, 2016 6:19 AM
  • Hi Seidkhan,

    Since your issue is out of our support scope and you haven't come back for a long time. Now I will move your case to Off topic, thanks for your understanding.

    If you have any issue related to the very core of .NET, please feel free to post in this forum.

    Best regards,

    Kristin


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, March 29, 2016 5:33 AM