COM class factory error: 8000401a.


  • Hello

    I have been trying to solve this problem since many days. I created charts on my web page using chart control and then saved those charts in temp folder. I want to export thses charts to excel file . The good thing is , I was able to that on my local machine.
    But whenh I put the same code in server 2003 , I start getting error :
    Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 8000401a.

    on this line:
    xlApp = new Excel.ApplicationClass();

     I think I have tried every solution avaialable but seems I am still missing on something. Can someone please help me step by step to follow some tutorial. I know this perms problem , but where I dont know..
    Please help ?


    Thursday, April 09, 2009 8:46 PM

All replies

  • Does the server 2003 machine have the excel assemblies in its GAC?
    Thursday, April 09, 2009 9:41 PM
  • I have no idea how to check that ? Can you please let me know ... I really appreciate it


    Thursday, April 09, 2009 11:48 PM
  • Friday, April 10, 2009 1:23 AM
  • The Global Assembly Cache tool allows you to view and manipulate the contents of the global assembly cache and download cache: Gacutil.exe


    Friday, April 10, 2009 1:31 AM
  • 8000401a means:

    The server process could not be started because the configured identity is incorrect. Check the username and password.
    Friday, April 10, 2009 1:33 AM
  • is there any specific excel assembly name that I should check in c:\windows\assembly ?

    Friday, April 10, 2009 1:36 AM
  • I just checked in this folder and i can see in it... Is there any other that I should be looking here ?
    Friday, April 10, 2009 2:43 AM
  • Any help ?
    Monday, April 13, 2009 3:35 AM
  • Hi Varun,
            THis is due to that reason that it is not able to create the COM object fo excel.

    Is it registered properly in the machine? Go to registry and check path - "HKEY_CLASSES_ROOT\CLSID\{00024500-0000-0000-C000-000000000046}".

    If is it exists, try below vb script ("Excel.Application.12" is the value in "HKEY_CLASSES_ROOT\CLSID\{00024500-0000-0000-C000-000000000046}\ProgID")

    Is the office properly registered for all users?

    Monday, April 13, 2009 4:16 AM
  • Many thanks for replying back to this thread!!
    I check at the locations in registry as guided by you...

    HKEY_CLASSES_ROOT\CLSID\{00024500-0000-0000-C000-000000000046}\ProgID" is having Excel.Application.11

    I think I should uninstall office 2003 and put office 2007 as the same code on my developemnt machine works where i have office 2007 ?
    Any suggestions on that ?

    Monday, April 13, 2009 8:22 PM
  • Hi Varun,

    It should be the permissions problem.
    Please have a try using the following steps to Configure DCOM:
    1. Go to the Start-Run menu to type in "dcomcnfg"  and hit enter to load "Component Services" MMC.
    2. Select the "Microsoft Excel Application" item through "Component Services" MMC->Component Services->Computers->My Computer->DCOM Config->Microsoft Excel Application
    3. Right click and select Properties->Select Identity Tab->Select This user and add the Administrator accout and password
    4. Select Security Tab, Under "Launch and Activation Permissions", Choose "Customize", Click "Edit" button, Add the everyone account and add all the Permissions.
    5. Do the same thing in "Access Permissions" and "Configuration Permissions"

    Best regards,
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Proposed as answer by kreativekai Tuesday, April 26, 2011 12:23 PM
    Tuesday, April 14, 2009 10:26 AM
  • Hi Varun,
        Did CreateObject in vbscript work?

    Tuesday, April 14, 2009 2:08 PM
  • Hello GUO

    I have tried all those settings :
    Currently it is set to Launching User , but even if I change to admin user and password:
    It gives me:

    Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80080005 

    Hey Vic

    CReateObject in VBScript ? what does that mean .... Please tell me how can I test that ?
    Tuesday, April 14, 2009 4:43 PM
  • Probably there is no such class in the COM server.  You'll have to download and install the SDK that controls it.
    • Proposed as answer by Guo Surfer Friday, April 17, 2009 2:40 AM
    Wednesday, April 15, 2009 12:16 AM
  • Hi Varun,

    Create a VbScript (call a.vbs). Then add CreateObject("Excel.Application.11") in the file. Double click the file.
    Also, Which OS are you using?

    Wednesday, April 15, 2009 3:41 AM
  • Thanks Guo!   This worked to fix this problem for me on Windows Server 2008!   Thanks again!
    Lost in the Vast Sea of .NET
    Tuesday, April 26, 2011 12:24 PM
  • Thanks Guo.

    It worked !!!!


    Tuesday, June 21, 2011 11:04 AM
  • Thanks Its working fine For this i strugled so much .
    Monday, September 19, 2011 7:22 AM
  • Thanks Guo.. I have the same issue and the above configuration solved the issues in Windows 2008 R2 Server .
    Thursday, September 29, 2011 6:21 AM
  • Hi Guo,

    Thank and it works in my Windows 2008 R2 and IIS server.


    Pathiraja Dissanayaka.

    Friday, February 24, 2012 4:45 AM
  • Error : Retrieving the COM
    class factory for component with CLSID {00024500-0000-0000-C000-000000000046}
    failed due to the following error: 8000401a.

    it should be the permission problem in Microsoft Excell Application in Dcomconfig

    see this post for more details:


    Harikrishna Bura

    Sunday, March 11, 2012 6:01 AM
  • Hi Guo,

    It works..!

    Thanks for the solution..

    Tuesday, March 13, 2012 6:09 AM
  • Hi, Varun.

    Thanks for your solution.

    My problem solved.

    From Angie


    Thursday, June 12, 2014 7:11 AM
  • Hi

    You said ->

    Right click and select Properties->Select Identity Tab->Select This user and add the Administrator accout and password

    What if the user changes his password?

    Every time need to provide the Password(After user changes his password) if that issue arises?

    --Thanks & Regards


    Tuesday, April 18, 2017 9:16 AM