none
Allegro - Cannot open file ..../Program.obj Error:0x80070002 RRS feed

  • Question

  • Hello Everyone !

    I have problem with latest allegro library, after install it from nuGet and type some basic code i have an error - Cannot open file ..../Program.obj Error:0x80070002 :/ 

    Help me ! 

    Thank You,Sebastian

    Thursday, December 12, 2019 5:50 PM

All replies

  • Hi Sebastian,

    Welcome to MSDN forum.

    Did you configure your allegro library for your project in visual studio? Please go to Properties/Allegro 5,  then set the library type to "Dynamic Debug - Dynamic runtime",

    And set Add-on you want in your project, to "Yes", then check if it could work.

    Any feedback will be greatly expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, December 13, 2019 2:04 AM
  • Yes, i Did it. Thank you for respond, hope you will help me !

    Edit: Run as administrator, dont solves that

    • Edited by Windica Friday, December 13, 2019 1:41 PM
    Friday, December 13, 2019 1:37 PM
  • Up ! somebody ?
    Saturday, December 14, 2019 9:44 AM
  • Hi Windica,

    Sorry for delay in reply.

    Could you share the code which could help us reproduce this issue here? And you could also try to  build the blank project with allegro package.

    Looking forward to your feedback.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, December 16, 2019 9:57 AM
  • #include "stdafx.h"
    #include "allegro5\allegro.h"

    int main(int argc, char** argv) {
    al_init();

    al_create_display(640, 480);

    al_clear_to_color(al_map_rgb(255, 0, 255));

    al_flip_display();

    al_rest(5.0f);

    return 0;
    }

    error same as later + 

    „C:\Windows\SysWOW64\imm32.dll”. can not founr or open PDB. on all .dll files.

    Win reinstall dont help, maybe its problem with ram, may be? 

    Tuesday, December 17, 2019 7:24 PM
  • Hi Windica1,

    Thank you for feedback.

    I have test your code on my side, it could work.

    Could you build your project without any error in VS IDE? Then you could try to run the exe file in file explorer, to check if it could work without debugger.

    In addition, please go to Tools|Options|Debugging|General, then disable "Enable Just My Code", and go to "Symbols" to enable "Microsoft Symbol server". Then re-debug your project.

    Any feedback will be expected.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, December 18, 2019 9:52 AM
  • Where is the build option, you mean compile ? I use VS IDE 2017 and 2019, on both version same problems.

    Now i have another problem - "Cant open program /ConsoleAplication.exe Cant found file". 

    There is no .exe file in my project :/

    Everything is okay with my RAM/HDD.

    Thursday, December 19, 2019 6:30 PM
  • anyone ? 
    Thursday, December 26, 2019 11:41 AM