none
Get error when install one nuget package RRS feed

  • Question

  • My team member trying to add a nuget package PiranhaCMS to one of project. But he got the following error when he try to install it:

    'xxx' already has a dependency defined for 'NETStandard.Library'

    But our project is .net, so why we got that error? Thanks any advice.

    Wednesday, April 4, 2018 10:13 PM

Answers

  • Hi Kevin YL,

    Thanks for posting here.

    What version of Visual Studio does your team member use? Is an old Visual Studio 2012 and below? If yes, you will get that error. That because full NetStandard and NetCoreApp support for VS2013. so we will get that error when we install the package "PiranhaCMS" by Visual Studio 2012 and below. You can refer to the NuGet release note for 2.12 for detail info.

    To resolve this issue, you should use a higher version of VS, like Visual Studio 2013. I have install it on the Visual Studio 2013 successfully.


    MSDN Community Support Please remember to click Mark as Answer. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, April 5, 2018 9:19 AM

All replies

  • Hi Kevin YL,

    Thanks for posting here.

    What version of Visual Studio does your team member use? Is an old Visual Studio 2012 and below? If yes, you will get that error. That because full NetStandard and NetCoreApp support for VS2013. so we will get that error when we install the package "PiranhaCMS" by Visual Studio 2012 and below. You can refer to the NuGet release note for 2.12 for detail info.

    To resolve this issue, you should use a higher version of VS, like Visual Studio 2013. I have install it on the Visual Studio 2013 successfully.


    MSDN Community Support Please remember to click Mark as Answer. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, April 5, 2018 9:19 AM
  • Hi Leo, Thanks for your answer, yes, It is VS 2012. May I install the nuget 2.12 in my VS2012, so that I do not need to update my VS, it will take a long time.
    Thursday, April 5, 2018 12:15 PM
  • @Kevin, you could not, that because the latest nuget for Visual Studio is 2.8, you have to update to Visual Studio 2013 if you want install that nuget package.

    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 5, 2018 5:07 PM
  • OK, I will try, then let you know if it work for me.
    Thursday, April 5, 2018 6:31 PM