Remote debugging monitor as service: Servername?


  • Hello

    I successfully remote debugged my application with remote debugging monitor started as application, but I can't get it working as a service.
    Visual Studio always prints the message "There is no server by the specified name running on the remote computer" or "Unknown username or bad password". Sometimes I don't even change anything and suddenly get the other message.
    I'm using the same local user and according to the documentation it should use "username@computername" as servername, but it doesn't work.
    I've tried "servername\username@servername" and "servername" aswell... without success. I know that the servername is case sensitive and I've tried these servernames with all uppercase and all lowercase, too.
    The security event log of the computer running remote debug monitor service shows a successful logon and logoff of the user used for debugging.
    The securtiy event log of my development machine shows some failed logons of this user. I have no idea why.

    What should be the servername exactly? Can I find it out somehow?
    Any other ideas?

    EDIT: I was able to find out something more. Unfortunately it didn't become less confusing.
    1. I started debugging and got the error message "There is no server by the specified name...".
    This caused an entry of a successful logon in the eventlog of the test-machine and there was no entry in the security log of my dev-pc.
    2. Without changing anything I tried debugging again and got the error message "Wrong username or bad password".
    This caused no entry in the test-pc's eventlog, but a failed logon entry in my dev-pc's security log. The logon-account was System.
    3. Tried again. The same things happened as in step 2.

    It seams like the message in step 1 only apears if I do nothing for a while and the other message apears if I try it again after a failed attempt.
    I have no clue about what's happening here.
    Wednesday, August 12, 2009 11:57 AM

All replies

  • Hello,

    The Qualifier we entered in the attache to process dialog box formatted as "<domainName>\<userName>@<MachineName>", for example, mydomain\user@machinename

    Would you please try and tell me the result?
    Best regards,
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback, please tell us.
    Welcome to the All-In-One Code Framework!
    Thursday, August 13, 2009 9:13 AM
  • I'm sorry for not answering earlier.
    I'm not using a domain account because the test computer is either not in a domain at all, or in a different one. My program is for joining a domain, so I can't change this.
    I've tried machinename\user@machinename, WORKGROUP\user@machinenemae and user@machinename. No Success.
    At the moment I'm only getting the first message ("There is no server by the specified name running on the remote computer"). Don't know why.

    EDIT: The error about the wrong username or password is resolved. The local user account on my dev-machine wasn't in the administrators group.
    I've installed wireshark to find out more about the other problem. Unfortunately I'm not a network crack and don't understand what's going on in all details.

    I've found an smb request for the path "\Microsoft.VisualStudio.9.0.Remote\[username]".
    I'm not sure what sort of path it is. The remote-machine returns "ERROR: STATUS_OBJECT_NAME_NOT_FOUND".
    After that, there's another request of the same type but with the path "\Microsoft.VisualStudio.9.0.Remote\[MACHINENAME]\[username]".
    The answer is the same error message again.

    Running the remote debug monitor as an application the requested path is: "\Microsoft.VisualStudio.9.0.Remote\[username]"
    This request seams to be granted and the communication continues.

    EDIT2: I can connect to WXP-CLIENT in the "Attach to Process"-Menu. When I start the service, I first have to list the processes on the local machine, then I can type "WXP-CLIENT" into the "Qualifier"-Box and hit "Show processes from all users.
    It doesn't work if I don't connect to the local machine first. Just hitting "Refresh" or checking and unchecking the "Show processes from all users"-Checkbox doesn't work ("Unable to connect to the Microsoft Visual Studio Remote Debugging Monitor named 'WXP-CLIENT'").

    I start wondering if this is a bug... I've red all documentation I could find and checked every setting that could be related to this. STILL NO SUCCESS!

    • Edited by Bef Monday, August 17, 2009 2:36 PM
    Monday, August 17, 2009 11:01 AM