none
.Net 4.6 will not install on Server 2012 R2 - updates suggested are for Windows Server 8.1 RRS feed

  • Question

  • I am trying to install .Net 4.6 on a Server 2012 R2 System.  When I run it I get:  "Blocking Issues: The update corresponding to KB2919355 needs to be installed before you can install this product on Windows 8.1 or Windows Server 2012 R2"

    So I searched for KB2919355 - and selected... "Download the x64-based Windows Server 2012 update package now.    Which took me to this page... https://www.microsoft.com/en-us/download/details.aspx?id=42334  - I then pick "Download" button.  It brings me to downloads for Windows 8.1 not Server 2012 R2. 

    I download anyway the 8.1 version of KB2919355 and try to install it.  I get "Windows Update Standalone Installer...  This update is not applicable to your computer."

    I have tried others with same results, the updates are for Windows 8.1 not Server 2012 R2 and therefore will not install. 

    Where do I get updates for Windows 2012 R2 so that I can install .NET 4.6?   This is for a 64-bit operating system.  This system does not have internet access so I need to be able to download files to install from.

    This is holding up testing of software for my company and  I am desperate for help. 

    Best,

    Donna

    Monday, June 13, 2016 3:49 PM

Answers

  • Dear DonnaSilveri,

    Welcome to the MSDN forum.

    According to the error message “Blocking Issues: The update corresponding to KB2919355 needs to be installed before you can install this product on Windows 8.1 or Windows Server 2012 R2”, I found this KB document: https://support.microsoft.com/en-sg/kb/2919355

    After compare the stand-alone update packages between Windows 8.1 and Windows Server 2012 R2, I find the file name and size are the same, it looks like the update packages are apply to Windows 8.1 and Windows Server 2012 R2. From this article, I found the following message:

    1. To apply this update 2919355, you must have the update 2919442 installed on the computer.

    2. The updates must be installed in the following order: clearcompressionflag.exe, KB2919355, KB2932046, KB2959977, KB2937592, KB2938439, and KB2934018.

    Please make sure you already followed the above instructions and if it still install failed, please go to the installation log of this update and find the detail error message, there also have some known issues with this update in the above KB article.

    If this update still cannot install on your computer, maybe you raise the update issue in the Windows Server 2012 R2 general forum: https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?forum=winserver8gen for more professional support. Since our forum is to discuss the .NET Framework Setup and Servicing, after you successfully install this update, the .NET Framework 4.6 still cannot install, upload the .NET Framework installation log file to https://onedrive.live.com/ and share the link here.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 14, 2016 2:34 AM
    Moderator

All replies

  • Dear DonnaSilveri,

    Welcome to the MSDN forum.

    According to the error message “Blocking Issues: The update corresponding to KB2919355 needs to be installed before you can install this product on Windows 8.1 or Windows Server 2012 R2”, I found this KB document: https://support.microsoft.com/en-sg/kb/2919355

    After compare the stand-alone update packages between Windows 8.1 and Windows Server 2012 R2, I find the file name and size are the same, it looks like the update packages are apply to Windows 8.1 and Windows Server 2012 R2. From this article, I found the following message:

    1. To apply this update 2919355, you must have the update 2919442 installed on the computer.

    2. The updates must be installed in the following order: clearcompressionflag.exe, KB2919355, KB2932046, KB2959977, KB2937592, KB2938439, and KB2934018.

    Please make sure you already followed the above instructions and if it still install failed, please go to the installation log of this update and find the detail error message, there also have some known issues with this update in the above KB article.

    If this update still cannot install on your computer, maybe you raise the update issue in the Windows Server 2012 R2 general forum: https://social.technet.microsoft.com/Forums/windowsserver/en-US/home?forum=winserver8gen for more professional support. Since our forum is to discuss the .NET Framework Setup and Servicing, after you successfully install this update, the .NET Framework 4.6 still cannot install, upload the .NET Framework installation log file to https://onedrive.live.com/ and share the link here.

    Best regards,

    Sara


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 14, 2016 2:34 AM
    Moderator
  • Hi Sara, 

    Thanks for your informative guidans, I had the same problem  “Blocking Issues: The update corresponding to KB2919355 needs to be installed before you can install this product on Windows 8.1 or Windows Server 2012 R2”,  but after followed your instructions and now successfully installed the .NET Framework 4.6.1 setup. Thanks

    Regards,

    Kamran 

      

    Thursday, January 12, 2017 9:38 AM
  • Great Article... Helped resolve my issues... 

    This is what did it for me.

    1. To apply this update 2919355, you must have the update 2919442 installed on the computer.

    2. The updates must be installed in the following order: clearcompressionflag.exe, KB2919355, KB2932046, KB2959977, KB2937592, KB2938439, and KB2934018.


    Saturday, March 4, 2017 6:04 PM