none
Diagnostic Monitoring does not work on Azure Stack Single Node deployment RRS feed

  • Question

  • I successfully install a single node using the following document:

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-run-powershell-script

    I am fully deployed and working. Now I need to enable diagnostic Monitoring. In the Virtual Monitor Portal I click on on "more" and scroll down to Monitoring and click it. There is only one choice under it Diagnostics. (Please note if I do a 4 node deployment under Monitoring there are 4 choices). I click Diagnostic then a new screen pops up where we can choose what we want to monitor. There is a Overview option I click that and underneath I choose what all I want to monitor and then click Enable Monitoring. I click on "Connect" and start my VM. It starts and then then a new screen flashes saying CPU percentage but it says "No available data" so nothing gets displayed. Some times it just blinks, some times it just puts some blinking dots and never a trace. I have tried 10-15 times all possible means but it just does not work. 4 node deployment works just fine. I have googled and binged there is not information as to how to set Diagnostic Monitoring on a single node. Please point me to doc or help me how I can fix this issue.  

    Tuesday, February 27, 2018 6:30 AM

Answers

  • Hello Ananda,

    Regarding the ASDK monitoring graph, the following needs to be performed:

    1. Enable Microsoft.Insights Resource Provider for the subscription

      - Subscriptions  <subscription name>  Resource Providers

    2. Enable Guest OS Diagnostics

      - Existing VM: Virtual Machines <vm name>  Diagnostics Settings

      - Create new VM with Guest OS Diagnostics selected

    3. Configure Monitoring Chart with specific counters

      - The default counter for the VM is pointing to non-existent counter. This needs to be updated by select on the Monitoring Chart and select Edit Chart. You can select any number of counters that are enabled.   

    NOTE: Linux Virtual machines can’t have diagnostics enabled at this time          

       

    And here's a video that is still useful even though based on a the pre-GA UX https://m.youtube.com/watch?v=juAv3o7_CZU

          

    Let us know how it goes.

                                

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you experience any issues with Azure Stack or the current ASDK release, please feel free to contact us.

                

     Thanks


    Gary Gallanes




    Tuesday, February 27, 2018 8:45 PM
    Moderator
  • Thanks Gary finally I got it working. The video helped although as you said it was bit dated. I would like to add one screen shot where Charles Joy and my procedure differs. On the Monitoring screen you have to just double click and then you will get another screen where you can do the Edit to enable the desirable counters. So the enabling of the counters have to happen twice, once by clicking Monitoring --> Diagnostic --> Configure and once more by double clicking on the Monitoring/Cpu Percentage page. I was desperate and just double clicked and there I had a Edit screen :-). Enjoy. 

    Wednesday, February 28, 2018 2:02 AM
  • Hello,

    I see you have the counter set as:

    Process(*)\WorkingSet

      

    Can you try setting it as:

    Process(total)\workingSet

         

    Let us know how it goes.

        

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you experience any issues with Azure Stack or the current ASDK release, please feel free to contact us.

         

     Thanks


    Gary Gallanes

    Thursday, March 1, 2018 11:03 PM
    Moderator

All replies

  • Finally I found one promising URL:

    https://docs.microsoft.com/en-us/azure/monitoring-and-diagnostics/azure-diagnostics-troubleshooting

    I will try this out and if this fixes the issue will update my report meanwhile any help/idea ares welcome.

    Tuesday, February 27, 2018 6:24 PM
  • Hello Ananda,

    Regarding the ASDK monitoring graph, the following needs to be performed:

    1. Enable Microsoft.Insights Resource Provider for the subscription

      - Subscriptions  <subscription name>  Resource Providers

    2. Enable Guest OS Diagnostics

      - Existing VM: Virtual Machines <vm name>  Diagnostics Settings

      - Create new VM with Guest OS Diagnostics selected

    3. Configure Monitoring Chart with specific counters

      - The default counter for the VM is pointing to non-existent counter. This needs to be updated by select on the Monitoring Chart and select Edit Chart. You can select any number of counters that are enabled.   

    NOTE: Linux Virtual machines can’t have diagnostics enabled at this time          

       

    And here's a video that is still useful even though based on a the pre-GA UX https://m.youtube.com/watch?v=juAv3o7_CZU

          

    Let us know how it goes.

                                

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you experience any issues with Azure Stack or the current ASDK release, please feel free to contact us.

                

     Thanks


    Gary Gallanes




    Tuesday, February 27, 2018 8:45 PM
    Moderator
  • Thanks Gary finally I got it working. The video helped although as you said it was bit dated. I would like to add one screen shot where Charles Joy and my procedure differs. On the Monitoring screen you have to just double click and then you will get another screen where you can do the Edit to enable the desirable counters. So the enabling of the counters have to happen twice, once by clicking Monitoring --> Diagnostic --> Configure and once more by double clicking on the Monitoring/Cpu Percentage page. I was desperate and just double clicked and there I had a Edit screen :-). Enjoy. 

    Wednesday, February 28, 2018 2:02 AM
  • Hi Gary,

    Alas the success was applicable to Memory Bytes only. As you can see the 2nd image the Process(*)Working Set does not show up. So what I did was disabled and got rid of Memory plugin and just enabled Processor Time. That is the minimal of minimal. That also does not work. Please check the first image. Again I get the "No available data". I have done it Past 1 hour, Past 1 day and all combination. I increased the sampling rate from default 60 - 6000 that also did not help. I am subscribed to my Insights still and in the Configuration and Edit windows the selected plugin is enabled. Please advice. Thanks


    Thursday, March 1, 2018 7:05 PM
  • Hello,

    I see you have the counter set as:

    Process(*)\WorkingSet

      

    Can you try setting it as:

    Process(total)\workingSet

         

    Let us know how it goes.

        

    We apologize for any inconvenience and appreciate your time and interest in Azure Stack.

    If you experience any issues with Azure Stack or the current ASDK release, please feel free to contact us.

         

     Thanks


    Gary Gallanes

    Thursday, March 1, 2018 11:03 PM
    Moderator
  • Whew!! I realize me mistake. Thanks a bunch.  I have one more request please.

    What I did was do a perftype -q and and created the Perfmon plugin list and used them for MAS monitoring. That was the mistake the formats are incompatible. Could you please tell me how I can list all the plugins supported by Azure Stack. That list will be in the proper format compatible to MAS diagnostic monitoring so i dont commit the same mistake again.

    Thanks & regards

    ananda

    Thursday, March 1, 2018 11:54 PM
  • I think from what I can see from Monitoring Diagnostic settings there are 6 broad categories, totally 198 plugins and the only difference between the Perfmon and Monitoring Diagnostic plugins is (*) is replaced by (_Total)

    If I am wrong please let me know or else I will assume this as the closest to the fact

    Friday, March 2, 2018 9:16 PM