none
7 KB updates for VS 2010 Pro fail to install via Windows Install facility RRS feed

  • Question

  • Win 7/64 : all OS patches, installed.

    Using Microsoft Visual Studio Pro 2010 Version 10.0.40219.1 SP1Rel (original install of VSS Pro was 10.0.30319).

    FrameWorks installed: Microsoft .NET Framework Version 4.5.50709 SP1Rel, and Framework 4 Multi-Targeting Pack are installed.

    VSSP KB's installed now: KB2529927l, KB2542054, KB2549864, KB635973, KB2736182, KB983509, KB2644980 , KB2645410.

    About ten-days ago, seven KB updates for VS 2010 appeared in the Windows Update facility:

    1. Visual Studio 2010 Service Pack 1 (KB2565057): Windows Installer reports this as installing successfully, but every time I re-boot, it shows up as uninstalled, in the Windows Update facility again. Even thought the apparently successful install of this update does not require a "re-start," I have, as an experiment, shut down the computer immediately after installing only that KB. On re-boot, that KB appears in the Windows Install facility as uninstalled, again.

    2. The other six KB's: all fail to install with error code #66a.

    Visual Studio 2010 Service Pack 1 (KB2645410)
    Update for Microsoft Visual Studio 2010 Service Pack 1 (KB2529927)
    Update for Microsoft Visual Studio 2010 Service Pack 1 (KB2635973)
    Update for Microsoft Visual Studio 2010 Service Pack 1 (KB2736182)
    Update for Microsoft Visual Studio 2010 Service Pack 1 Report Viewer (KB2549864)
    Update for Microsoft Visual Studio 2010 Service Pack 1 Web Platform Tools (KB2548139)

    But, even though six out the seven KB updates fail to install, when I shut down the computer, the OS tells me it is installing seven updates: there is no error message shown, before the computer finally shuts down.

    Every time I go through the cycle of trying to install the updates, it creates a new "Restore Point," so I finally went and deleted about 11 of 12 restore points.

    Appreciate any advice !

    thanks, Bill


    Bill Woodruff



    • Edited by dotScience Friday, February 15, 2013 6:55 AM
    • Moved by Konrad Neitzel Friday, February 15, 2013 8:19 AM Installation issues
    Friday, February 15, 2013 6:44 AM

All replies

  • Hi Bill,

    I am sorry but I cannot help you on this issue. I will move the thread to the Visual Studio Setup and Installation forum for better support. The experts there hopfully can help you.

    With kind regards,

    Konrad

    Friday, February 15, 2013 8:18 AM
  • Hi,

    I think this issue more related to Windows update which you can submit it to:

    http://answers.microsoft.com/en-us/windows/forum/windows_update

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 18, 2013 6:39 AM
    Moderator
  • Mr. Jiang,

    Everyone of these seven updates are for Visual Studio 2010 Pro. And my computer tries and fails to install them everytime I shut it down.

    Other updates for Windows, in general, are installing properly: so this is a Visual Studio specific issue !

    This is the forum where this issue should be responded to; "updating" is definitely part of "setup," in my opinion, and I doubt the generic "Windows Update" forum will have technical support staff on-line familiar with the intricacies of Visual Studio.

    thanks, Bill Woodruff


    Bill Woodruff

    Wednesday, February 20, 2013 5:46 AM
  • Hi Bill,

    I have a few suggestions for you. Would you please:

    1. Run .NET Framework Repair Tool from here: http://www.microsoft.com/en-us/download/details.aspx?id=30135 This could fix .NET issues which blocks updates installation.
    2. Review Windows Update log from: C:\Users\***\AppData\Local\Temp\WindowsUpdate.log share the log with me if necessary.
    3. Run Windows Update Troubleshooter, and see if it can resolve the problems automatically.

    These updates are all for Visual Studio 2010 SP1, they're not SP1 though :)

    thanks.


    Forrest Guo | MSDN Community Support | Feedback to manager


    Friday, February 22, 2013 3:21 PM
    Moderator
  • Hi Bill,

    Have you made some progress regard to install these updates? Please feel free to let me know if you need assistance.

    thanks.


    Forrest Guo | MSDN Community Support | Feedback to manager

    Tuesday, February 26, 2013 2:50 PM
    Moderator
  • I have the same EXACT problem, literally.  I have this problem, as well as some other updates that will not install, which started about 10 days ago, like the OP.

    I tried all of the suggested fixes, and nothing got these updates to install.  They fail each time, no matter what I try.  I've tried dozens of fixit tools, and they almost always say they detect a problem with windows update, show that the problem has been fix, even though it hasn't.

    My PC has is showing that '!' to shutdown to install updates, but no matter how many times I shutdown or restart, it's there again after restart.  Nothing even tried to install when windows is loading, which seems to make sense, because the ! is never going away.

    I have no idea what else to try.  I even downloaded at ran every test in the microsoft fixit application, and still no luck.

    Sunday, March 24, 2013 2:06 PM
  • Hi Guys,

    I also am having the same problems installing many of these updates:

    KB2645410, 26335973 and 2890573 all fail error 66A.  I've tried the fixit, and update help, no luck.

    I am running Atmel Studio 6.1 release 2 which is based on Visual Studio 10.  Could this be the cause of these update failures?

    Thanks,

    Scott


    Scott

    Monday, January 6, 2014 1:41 AM