none
Sending mail from webbservice on cloud server using .net.smtpclient stopped working

    Question

  • Hi

    We have created a webbservice which is running on an Azure cloud-server on our domain.

    When we set this server up we configured mail for the webbservice using smtp.office365.com.

    In the webservice code we use .NET.smtpclient with host smtp.office365.com on port 587 with SSL and credentials from our cloud domain.
    This has worked well last time we tested the service in october 2016.
    The project has been put aside for a while, but now when we are about the start it up again, the mail-function is no longer working. We started a support-issue with Microsoft but when it worked to connect to smtp.office365.com using telnet they said it was an application error.
    They (Microsoft person) repeated that TLS was to be used instead of SSL, but that makes no sense since .NET FW 4.5 does not have any TLS options on its SmtpClient, only SSL.

    What may have changed regarding SmtpClient since last fall for this to stop working?

    Any help is appreciated.


    Best Regards Peter Karlström Midrange AB, Sweden

    Monday, March 20, 2017 6:26 PM

All replies