Windows Server 2012, can't install .NET 3.5


  • Hey guys,

      I am trying to install .NET 3.5 on Windows Server 2012, but none of the installation methods listed in:

    seem to work for me. For some reason, even when I am pointing the installations to the Sources\SxS folder on my installation media, I am still told that the source cannot be found.

    My CD drive is labeled D, and these are the commands I've tried (in powershell and command prompt):

    xcopy d:\sources\sxs\*.* c:\net35 /s
    Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:c:\net35 /LimitAccess

    Install-WindowsFeature Net-Framework-Core -source D:\sources\sxs\

    DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:d:\sources\sxs

    Any suggestions as to why I continually get the "Error: 0x800f081f - The source files could not be found." error? I've even tried installing this from Server Manager, and specifying the SxS folder via the GUI, but I receive the same error.


    Monday, December 03, 2012 12:45 PM


All replies