none
VS2019 Custom Debugger Visualizer for .Net Fx and Core

    Question

  • Hi,

    I have lots of custom Debugger Visualizers for .Net Fx and was unable to port them to VS2019 (RTM/GA). They simply don't show up in the debugger. During my tests I found that even the built-in Dataset Visualizer does not show up in VS2019 anymore (for a .Net 4.6.1 Application). I have also tried to create a new VSIX project, added an Item "Debugger Visualizer" and started the project, but the Visualizer didn't show up either. (My old Visualizers weren't VSIXs - I just copied them to C:\Users\fk\Documents\Visual Studio 2017\Visualizers )

    According to https://developercommunity.visualstudio.com/idea/351618/custom-debugger-visualizer-for-net-core-apps-in-vs.html Custom Debugger Visualizer should be available for .Net Core, too. But since I couldn't get them to work for .Net Fx, I had no luck for .Net Core either.

    And I haven't yet found a way to troubleshoot the visualizer discovery process.

    So, has anyone had success with this, or is this just buggy in VS2019? Is there any further information available on this topic?

    Wednesday, April 3, 2019 7:42 AM

Answers

  • Hi Frank,

    Sorry for the delay in reply.

    Firstly, the visualizers should be copied to the installation of VS 2019.

    And this issue seems to be a problem with visual studio, so I report this issue to the link below:

    https://developercommunity.visualstudio.com/content/problem/562662/vs2019-custom-debugger-visualizer-for-net-fx-and-c.html

    Then you could vote it and provide more information for further troubleshooting by adding comment.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Frank K. (LS) Thursday, May 9, 2019 8:47 AM
    Thursday, May 9, 2019 7:53 AM

All replies

  • Hi Frank,

    Sorry for the delay in reply.

    The issue has been submitted to MS developers. If there is any reply, I will update the information here. Thank you for understanding and patient.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com



    Thursday, April 4, 2019 8:25 AM
  • Hi Frank,

    Sorry for the delay in reply.

    Firstly, the visualizers should be copied to the installation of VS 2019.

    And this issue seems to be a problem with visual studio, so I report this issue to the link below:

    https://developercommunity.visualstudio.com/content/problem/562662/vs2019-custom-debugger-visualizer-for-net-fx-and-c.html

    Then you could vote it and provide more information for further troubleshooting by adding comment.

    Best Regards,

    Dylan


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Frank K. (LS) Thursday, May 9, 2019 8:47 AM
    Thursday, May 9, 2019 7:53 AM