none
Class not registered at ADOX.CatalogClass.Create(String ConnectString)

    Question

  • Hi,
       I added reference to COM Component  Microsoft ADO Ext. 2.8 for DDL and Security which added a wrapper DLL Interop.ADOX.dll in project references  in a web application to create MS Access database dynamically. It all works fine in development environment ( VS 2008 + Win 2003 Server. + 32-bit Machine)

    Code snippet is
    ADOX.CatalogClass db = new ADOX.CatalogClass();
    db.Create(conStr);

       The aformentioned web application is deployed on IIS 7 + Win server 2008 + 64 - bit machine, where it throws following exception
    System.Runtime.InteropServices.COMException (0x80040154): Class not registered at ADOX.CatalogClass.Create(String ConnectString)............... We have tried followings on the targeted web servers

    1.   1.)   Installed Access run time

          2.)   Installed Access full install

          3. )  Registered MSADOX.dll using REGSVR32 ( this fix was mentioned on number of forums)

          But, still no luck. Please, let me know what I am missing here to fix this.

    Thanks.

    T


     
    • Edited by XMOD Saturday, September 13, 2008 10:17 AM
    Saturday, September 13, 2008 8:28 AM

Answers

  • The Jet database engine has been deprecated for quite a while now.  There is no 64-bit version available for it.  You'll have to run IIS in 32-bit mode if you want to stick with the old stuff.  Post to forums.iis.net to find out how to do that.
    Hans Passant.
    Saturday, September 13, 2008 2:59 PM
    Moderator

All replies

  • The Jet database engine has been deprecated for quite a while now.  There is no 64-bit version available for it.  You'll have to run IIS in 32-bit mode if you want to stick with the old stuff.  Post to forums.iis.net to find out how to do that.
    Hans Passant.
    Saturday, September 13, 2008 2:59 PM
    Moderator
  • Hans thanks for the reply.
    I was able to fix this on same day after couple of more hours. You are right about JET, however.

    We just changed App Pool setting to run in 32-bit mode and that was all.
    Monday, September 15, 2008 4:52 AM