none
Visual Studio fails to launch! RRS feed

  • Question

  • Hi,

    I've downloaded the latest version of Visual Studio but, came across this issue (Could not start visual studio due to error. System.MissingMethodException: Method not found: Void System.Diagnostics.ProcessStartInfor.set_WorkingDirectory(System.String)).

    I haven't found a solution to fix this yet, would appreciate some help! 

    thanks. 

    Tuesday, February 12, 2019 3:28 PM

All replies

  • There is a similar question on Stack Overflow. I can't give a link, so try to search by yourself.

    Regards

    Tuesday, February 12, 2019 5:35 PM
  • Hi Abdul_,

    Welcome to MSDN forum.

    Please have a try with the following tips as below:

     

    1. Run the command: sfc /scannow to scan the required system file

    2. Disable any anti-virus

    3. Run visual studio as administrator


    If this issue persists, I need your help to gather the logs. Launch visual studio and run the command: devenv /log in the evaluated command prompt. And upload the file (%APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml) to https://onedrive.live.com/ and share the link here.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 13, 2019 2:48 AM
  • Hi Joyce, 

    Thanks for the help, the issue has not gone away. 
    I've tried to run devenv /log in the CMD but, the output was:

    'devenv' is not recognized as an internal or external command,
    operable program or batch file.

    Here is the link to the activity log: 

    https://chaseits-my.sharepoint.com/:f:/g/personal/abdullah_ali_chaseits_co_uk/EgWvMIwmcGVCpaD1ASBEHAUBPoVQqY_KXVGgMPQHgRqC0w?e=PcLz3S 


    Thanks

    Abdul

    Wednesday, February 13, 2019 10:24 AM
  • Hi Abdul, 

    Sorry for the delay, but it looks like i can't access your activity log.

    Please upload the file (%APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml) to https://onedrive.live.com/and share the link here.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, February 15, 2019 8:37 AM