locked
Cube (TFS_Analysis) fails to process RRS feed

  • Question

  • Hello

    I recently upgraded my TFS server from 2015.3 to TFS2017.2.

    I have App tier and Data tier with SQL2016 with KB3207512.

    we have about 20 collection (most are very small)

    when i check the diagnostic page i see that the full and incremental processing of the Tfs_Analysis fail.

    I have tried to rebuild the warehouse and analysis (from the Team foundation administration console)

    i have also tried to invoke a full analysis processing from the web service.but i keep getting error like:

    "  [Incremental Analysis Database Sync]:  
     AnalysisDatabaseProcessingType=Full, needCubeSchemaUpdate=True.
     Microsoft.TeamFoundation.Warehouse.WarehouseException: TF221122: An error occurred running job Incremental Analysis Database Sync for team project collection or Team Foundation server TEAM FOUNDATION.
     Microsoft.TeamFoundation.Warehouse.WarehouseException: Failed to Process Analysis Database 'Tfs_Analysis'.
     Microsoft.TeamFoundation.Warehouse.WarehouseException:
    Warning: Errors in the OLAP storage engine: The attribute key cannot be found when processing: Table: 'dbo_vDimTestRunOverlay', Column: 'Title', Value: 'VSTest Test Run release any cpu'. The attribute is 'Test Run Title'.Errors in the OLAP storage engine: The process operation ended because the number of errors encountered during processing reached the defined limit of allowable errors for the operation.
    Errors in the OLAP storage engine: An error occurred while the 'Test Run' attribute of the 'Test Run' dimension from the 'Tfs_Analysis' database was being processed.
    Internal error: The operation terminated unsuccessfully.
    Errors in the high-level relational engine. The database operation was cancelled because of an earlier failure.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'vDimWorkItemOverlay', Name of 'Work Item' was being processed.
    Errors in the OLAP storage engine: An error occurred while the 'Microsoft_VSTS_Common_ResolvedDate' attribute of the 'Work Item' dimension from the 'Tfs_Analysis' database was being processed.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'vDimWorkItemOverlay', Name of 'Work Item' was being processed.
    Errors in the OLAP storage engine: An error occurred while the 'Microsoft_VSTS_Scheduling_DueDate' attribute of the 'Work Item' dimension from the 'Tfs_Analysis' database was being processed.
    Errors in the high-level relational engine. The following exception occurred while the managed IDbCommand interface was being used: The request failed to run because the batch is aborted, this can be caused by abort signal sent from client, or another request is running in the same session, which makes the session busy.
    Operation cancelled by user.."

    Thank you

    Thursday, November 2, 2017 10:20 AM

Answers

  • we found the cause :

    we were missing TFS service account in the AS (Analysis service) security.

    we also found that the AS collation was incorrect.

    after we fixed those 2 , deleted the TFS_analysis and ran rebuild the processing was completed successfully

    thanks for all the suggestions

    • Marked as answer by Liran Dobrish Saturday, November 11, 2017 5:43 PM
    Saturday, November 11, 2017 5:43 PM

All replies

  • hi Liran,

    try to rebuild the DWH and Cube such that a full load and not incremental load is performed.


    Please use "Mark as Answer" if my post solved your problem and use "Vote As Helpful" if a post was useful.

    Thursday, November 2, 2017 5:30 PM
  • Hi Liran,

    How did you rebuild the warehouse and analysis? Please try to delete the Tfs_Analysis database by connecting to Analysis Service in Microsoft SQL Server Management Studio, expanding the Databases node, and deleting the Tfs_Analysis database.

    Then rebuild them in TFS administration console by following the article below:

    https://docs.microsoft.com/en-us/vsts/report/admin/rebuild-data-warehouse-and-cube


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Friday, November 3, 2017 6:43 AM
  • I rebuild the cube from the "Team foundation Administration console" and got similar results.

    I'll try to delete the TFS_Analysis and rebuild.

    I'll update when it's perfromed

    Sunday, November 5, 2017 1:26 PM
  • Hi Liran,

    Is your issue resolved?

    Best regards,


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, November 9, 2017 2:24 AM
  • we found the cause :

    we were missing TFS service account in the AS (Analysis service) security.

    we also found that the AS collation was incorrect.

    after we fixed those 2 , deleted the TFS_analysis and ran rebuild the processing was completed successfully

    thanks for all the suggestions

    • Marked as answer by Liran Dobrish Saturday, November 11, 2017 5:43 PM
    Saturday, November 11, 2017 5:43 PM