Program database manager mismatch RRS feed

  • Question

  • I have been working with vc++ express for about a month, and all my projects were fine but now whenever I compile anythingi get the following error:

    fatal error C1902: Program database manager mismatch; please check your installation

    I searched for a solution on Google and MSDN but neither showed anything i could make sense of.
    Wednesday, August 31, 2005 6:30 PM


  • You have a corrupt install. Basically you have the wrong version of DLLs used to generate PDB files installed. Some other install must have trashed the ones that came with Visual C++ Express.

    Wednesday, August 31, 2005 7:40 PM

All replies

  • You have a corrupt install. Basically you have the wrong version of DLLs used to generate PDB files installed. Some other install must have trashed the ones that came with Visual C++ Express.

    Wednesday, August 31, 2005 7:40 PM
  • thanks for telling me what the problem is, but how to solve it? SHould i reinstall vcexpress?
    Thursday, September 1, 2005 1:20 AM
  • Hi,

    I tried to run dumpbin.exe from its installed location, \Program Files\Microsoft Visual Studio 8\VC\bin, but the OS complained that it couldn't find mspdb80.dll.  I copied mspdb80.dll from \Program Files\Microsoft Visual Studio 8\Common7\IDE and dumpbin.exe ran fine.  Shortly afterward, however, I got error C1902 while building a project that had built just fine earlier in the day.  I removed mspdb80.dll from \Program Files\Microsoft Visual Studio 8\VC\bin and error C1902 went away.  Rather strange.

    Tom Lake

    Same happened to me
    Jose Luu
    • Proposed as answer by Pierre Shen Tuesday, June 8, 2010 8:05 AM
    Wednesday, November 23, 2005 10:13 PM
  • Same here. Reverted back to Beta 2 and everything was ok. :(

    Monday, November 28, 2005 9:51 PM
  • removing the mspdb80.dll from C:\ProgramFiles\Microsoft Visual Studio 8\VC\bin solved it for me.
    • Proposed as answer by BillNew Wednesday, January 26, 2011 7:20 PM
    Friday, June 2, 2006 6:05 PM
  • Yes, my situation is the same. After removing the mspdb80.dll, all the errors disappear. I don't know why.
    Tuesday, August 8, 2006 12:54 AM
  • Same problem here on 8/28/2006.  Thanks for the fix!  Hopefully Microsoft will fix this so that dumpbin and the C++ compiler can both find mspdb80.dll without the developer having to toy with it to get it to work.
    Monday, August 28, 2006 8:18 PM
  • Yr suggestion helped me too. Thanks.
    Friday, September 15, 2006 11:51 AM
  • I am getting the same error, but am using the team edition for developers.

    I have tried all 32 combinations in turn with restarts of dev studio and still get the error - sometimes it works for a build, but then another restart and it is broken again. I am deleting ALL temp files and the .ncb.

    Identical PC versions:
    C:\Program Files\Microsoft Visual Studio 8\Common7\IDE
    C:\Program Files\Microsoft Visual Studio 8\VC\bin
    C:\Program Files\Microsoft Visual Studio 8\Team Tools\Performance Tools
    C:\Program Files\Common Files\Microsoft Shared\VSA\8.0\VsaEnv

    360 version:
    C:\Program Files\Microsoft Xbox 360 SDK\bin\win32

    As long as the 360 version is there, the 360 builds fine, but not the PC.

    I can't think of any changes on my machine between working and not, apart from our TFS server was changed.

    All suggestions welcombe,

    Friday, October 6, 2006 9:52 AM

    It worked for me too. Thanks.

    Wednesday, January 24, 2007 9:33 PM
  • Guess it should be we've got some virus, that changes smth inside vc installation, cause after I repaired and reinstalled VS the error disappeared and later, next day came again, so it was enough time for a virus to "mark" new files.
    Sunday, March 25, 2007 12:27 PM
  • I just spent 4 hours with the most bizarre problem. I have VS 2005 Pro installed, & it's been working fine for over a year. Suddenly this evening I started getting C1902 errors, for everything I built. Nothing worked! I searched forum after forum, and then found this post here mentioning running dumpbin. Well, I had just done that, and started suspecting it. Other posts had mentioned that C1902 had to do with mspdb80.dll. And then it finally clicked. In order to get dumpbin to work, after adding its location to my PATH variable, I had to copy mspdb80.dll to \windows\system32. So I deleted it from there. My build problems magically disappeared. Talk about strange! And I have yet to find a post from Microsoft linking mspdb80.dll to C1902 build problems.
    Tuesday, April 10, 2007 12:12 AM
  • Had a very similar problem after fooling around trying to get a parallel make working (I couldn't). I hadn't touched any of the visual studio files, and was working exclusively in my c:\temp directory so I don't know quite what happened..!

    Did a search and found mspdb80.dll in the following locations:

    c:\program files\microsoft visual studio 8\common7\ide
    c:\program files\common files\microsoft shared\vsa\8.0\vsaenv
    c:\program files\microsoft sdks\windows\v6.0\vc\bin

    The one in the sdks directory was from 2005, the others were identical from 2006, and I'm using VS 05.

    I resolved it by renaming all but the one in the vs8\common7 directory.

    Apparently there's been a bug or two fixed by MS previously for this error, maybe there's another one somewhere Smile

    Thursday, August 30, 2007 10:57 AM
  • I have had the same problem. And  copying mspdb80.dll from \Microsoft Visual Studio 8\Common7\IDE   to   \Microsoft Visual Studio 8\VC\bin (instead  mspdb80.dll that was there) hasn't helped. But after mspdb80.dll has been deleted from VC\bin the problem disappears. 


    Sunday, October 12, 2008 8:45 PM
  • I'm getting the same error message and nothing I've tried here has helped. I have Microsoft Visual Studio 8.0 Express Edition installed. I only have mspdb80.dll in the \Microsoft Visual Studio 9.0\Common7\IDE folder and that's it.

    Anybody else have any ideas?
    Sunday, August 9, 2009 6:59 PM
  • Yep, got the same issue. I'm also running Microsoft Visual C++ 2008 Express on Windows XP and like you these suggestions here don't fix it.
    mspdb80.dll only exists on my system in...

    "C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE"

    I do have other express editons installed such as VB.NET and C#, even the 2010 beta 2. I wonder if these installations could be interfering with each other?

    Other than that, the only thing that I could find out about it was on MSDN. Quoted below, of which no download links or patches were given to fix or obtain the files. Any one got any other suggestions?

    Visual C++ Concepts: Building a C/C++ Program
    Fatal Error C1902


    Error Message

    program database manager mismatch; please check your installation

    A program database file (.pdb) was created using a newer version of mspdb80.dll than the one found while compiling.

    This error usually indicates that mspdbsrv.exe or mspdbcore.dll are missing or have different versions from mspdb80.dll. Ensure matching versions of mspdbsrv.exe, mspdbcore.dll, and mspdb80.dll are installed on your system.


    • Proposed as answer by Mulks Monday, November 23, 2009 2:36 PM
    Monday, November 23, 2009 1:48 PM
  • Hey all, I found the answer on someone else's blog when I googled it. I've just used it on the VC++ 2008 Express Edition instead. I've done this myself and it fixes the problem. You need to download the "Visual C++ 2005 Express Edition (Visual Studio 8)" and also download and install the "Visual C++ 2008 Express Edition (Visual Studio 9)".

    I couldn't find a link on the Microsoft site but I found a copy here.


    Once you have installed both versions goto the "\Common7\IDE" folder of the 2005 install ->

    "C:\Program Files\Microsoft Visual Studio 8\Common7\IDE"

    And copy these 3 files:


    to the "\VC\bin" directory of the 2008 installation ->

    "C:\Program Files\Microsoft Visual Studio 9.0\VC\bin"

    And eveything should work then. I think the reason that this problem is occuring is as mentioned earlier in this thread, that the vesrions of these files especially in the 2008 edition are mismatched and not compatible with each other. The files in the 2005 edition all work fine but only the ones from the "\Common7\IDE" directory which was clashing with the mspdb80.dll file in "\VC\bin", thus then deleting or copying over this version of the file then fixes it.

    • Proposed as answer by Mulks Monday, November 23, 2009 3:15 PM
    Monday, November 23, 2009 3:15 PM
  • I did the very same thing (even down to dumpbin), but the problem didn't show up until after a reboot, must've been dll caching.  Thanks for making the connection for me!
    Thursday, December 3, 2009 10:28 PM
  • same thing here with VS2008
    Sunday, February 14, 2010 5:35 PM
  • It worked for me too with VS2008. I had forgotten that I had done the dumpbin thing and had to copy a version of mspdb80.dll into, in my case C:\WINDOWS\, and I noticed that my installation had multiple versions (with obviously different sizes) of mspdb80.dll installed in various Visual Studio directories (I've got multiple versions installed).

    Apparentlly, the version in C:\WINDOWS\ was overriding the others but was the wrong version for the task at hand and needed to be deleted so the correct version could be found and used correctly. Either case, it worked like a charm, despite more than one uninstall/reinstall of VS2008...

    Thursday, March 18, 2010 4:34 AM
  • removing the mspdb80.dll from C:\ProgramFiles\Microsoft Visual Studio 8\VC\bin solved it for me.

    Almost... But instead of removing the file, try renaming it to mspdb80-old.dll just in case that file is needed again.

    In other words, don't cut the limb off of the tree while you are sitting on the limb.


    P. S. This did resolve the error!

    I am a Christian that believes that the Bible is true.
    Wednesday, January 26, 2011 7:20 PM
  • Same happend to me
    Wednesday, July 27, 2011 9:40 AM
  • The solutions of just removing  mspdb80.dll from "C:\Program Files\Microsoft Visual Studio 8\VC\bin" directory will stop working of dumpbin.exe.

    If you want dumpbin should also work fine, follow the steps:

    1) Remove mspdb80.dll from "C:\Program Files\Microsoft Visual Studio 8\VC\bin" folder.

    2) Add "C:\Program Files\Microsoft Visual Studio 8\Common7\IDE" to your "path" environment variable.

         You can add to the "path" environment variable in Windows 7 like this:

          Right click on  "My Computer" -> properties -> Advanced system settings -> "Advanced" tab -> Click on "Environment Variables".

          In the "System Variables" section scroll down to the variable name called "path" select it and click on "Edit".

          Here you can add the "C:\Program Files\Microsoft Visual Studio 8\Common7\IDE" by keeping a semicolon in front of the last path.

    Friday, April 13, 2012 6:17 PM