none
.net Framework continuing Install Problems RRS feed

Answers

  • Hi Ralph,

    Glad to hear from you again. And thank you for your email yesterday.

    I've looked into the log files that you attached. I found the exact the same error message in my last reply of the above link.

    To be honest, it's not one common error message. It's the first time that I came across this error code. I may have a try. I hope that I can help you on your concern.

    Could you please try upgrading Windows Installer to the latest Version 4.5?

    Let me know if it works.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, February 5, 2010 1:55 AM
    Wednesday, February 3, 2010 7:35 AM

All replies

  • Hi Ralph,

    Glad to hear from you again. And thank you for your email yesterday.

    I've looked into the log files that you attached. I found the exact the same error message in my last reply of the above link.

    To be honest, it's not one common error message. It's the first time that I came across this error code. I may have a try. I hope that I can help you on your concern.

    Could you please try upgrading Windows Installer to the latest Version 4.5?

    Let me know if it works.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, February 5, 2010 1:55 AM
    Wednesday, February 3, 2010 7:35 AM
  • Hello Yichun,
     
    I installed the latest version of the installer, 4.5 and was able to install the .net frameworks family update successfully. I then went to Windows Update to see if there was anything else that needed installing and it said I was up to date.
     
    Thanks for your help - again.
     
    Ralph
    • Marked as answer by Ralph Tomaccio Thursday, February 4, 2010 4:45 PM
    • Unmarked as answer by YiChun Chen Friday, February 5, 2010 1:55 AM
    Thursday, February 4, 2010 4:45 PM
  • Hi Ralph,

    It's my pleasure!

    Some notes to "Mark as Answer":
    We should mark the right answer to the post as Answer instead of marking the last reply in the post.
    This would be beneficial to other community members as well.
    Thus, I marked my reply as answer.
    Thank you for your understanding.  :)

    It's really good news to me! If you have any concern on .NET Framework installation, please feel free to let me know.

    Have a great weekend.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Friday, February 5, 2010 2:09 AM typo
    Friday, February 5, 2010 2:04 AM
  • Yichun - you are a genius! I've been battling this one for weeks and many hours. Upgrading to Windows Installer 4.5 fixed this issue.  My next step was a rebuild of the server, reinstalling a LOB app, AV, file shares and printers - not something I was looking forward to.

     

    Thank you.

    Monday, March 29, 2010 10:45 PM
  • Hi Helsby,

    I'm so glad to hear that this workaround helps you to solve your problem. It's my pleasure!

    Have a nice day.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, March 30, 2010 2:46 AM
  • Worked a treat for me too - nice one YiChun!
    Wednesday, December 8, 2010 10:34 AM
  • Hello Yichun,
    I have Windows Server 2003 latest patches until KB2446704.
    That didnt work for me. However i followed all the steps described here but windows installer 4.5 did solve the issue now i'm at the stage
    where the msi from 2.0 SP2 does not accept any patches on top of it

    On April 14 i installed the latest security updates where KB2446704 failed to install. I then went thru the suggested cleanup process and was able to install all until Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86 which fails with

    This patch contains 3 patches inside

    3.5 - OK

    3.0 - OK

    2.0 - fails

               ******* Product: {C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}
               ******* Action:
               ******* CommandLine: PATCH="d:\21c9c3807a9ad627830a\NDP20SP2-KB958481.msp" CURRENTDIRECTORY="d:\21c9c3807a9ad627830a" CLIENTUILEVEL=3  MSICLIENTUSESEXTERNALUI=1  CLIENTPROCESSID=3156
    MSI (s) (CC:18) [00:03:07:687]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (CC:18) [00:03:07:703]: End dialog not enabled
    MSI (s) (CC:18) [00:03:07:703]: Original package ==> C:\WINDOWS\Installer\8bc8fe.msi
    MSI (s) (CC:18) [00:03:07:703]: Package we're running from ==> C:\WINDOWS\Installer\8bc8fe.msi
    MSI (s) (CC:18) [00:03:07:718]: APPCOMPAT: looking for appcompat database entry with ProductCode '{C09FB3CD-3D0C-3F2D-899A-6A1D67F2073F}'.
    MSI (s) (CC:18) [00:03:07:718]: APPCOMPAT: no matching ProductCode found in database.
    MSI (s) (CC:18) [00:03:07:718]: MSCOREE not loaded loading copy from system32
    MSI (s) (CC:18) [00:03:07:718]: Note: 1: 2262 2: File 3: -2147287038
    MSI (s) (CC:18) [00:03:07:718]: Note: 1: 2262 2: MsiFileHash 3: -2147287038
    MSI (s) (CC:18) [00:03:07:718]: Opening existing patch 'C:\WINDOWS\Installer\a500857.msp'.
    MSI (s) (CC:18) [00:03:07:718]: Opening existing patch 'C:\WINDOWS\Installer\a500856.msp'.
    MSI (s) (CC:18) [00:03:07:718]: Opening existing patch 'C:\WINDOWS\Installer\a500855.msp'.
    MSI (s) (CC:18) [00:03:07:718]: PATCH SEQUENCER ERROR: {2F3AB6ED-951C-4CE7-8AC9-8546FDCF1F5A} patch does not specify the list of transforms in contains!
    MSI (s) (CC:18) [00:03:07:718]: Note: 1: 1708
    MSI (s) (CC:18) [00:03:07:718]: Product: Microsoft .NET Framework 2.0 Service Pack 2 -- Installation failed.

    MSI (s) (CC:18) [00:03:07:718]: Windows Installer installed the product. Product Name: Microsoft .NET Framework 2.0 Service Pack 2. Product Version: 2.2.30729. Product Language: 0. Installation success or error status: 1635.

    MSI (s) (CC:18) [00:03:07:718]: MainEngineThread is returning 1635
    MSI (s) (CC:B8) [00:03:07:718]: No System Restore sequence number for this installation.
    This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package.
    C:\WINDOWS\Installer\8bc8fe.msi

    If i try to run NDP20SP2-KB958481-x86 manually it shows me "none of the products are installed", tough .NET SP2 is installed and validation tool succeeds.

    I have tried all possible articles without any luck in the past 2 days.

    How can i find what this patch is {2F3AB6ED-951C-4CE7-8AC9-8546FDCF1F5A}?

    Is there a way to remove any uninstalled patches or is there any other solution that may cause the issue, before i go with reinstalling the whole machine.

    What i found is the following left overs inside %WINDIR%\Installer:

    KB974417, KB2418241, KB983583, KB976576, KB979909, KB976765, KB980773

    If they are not in the %WINDIR%\Installer or in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Patches

    Why does the wizard msi from 2.0 SP2 does not accept any patches? Each patch ends with "None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup." if i run it manually.

    Above error is when i run it from Microsoft Update.

    Now any patches fail to install on top of 2.0 SP2.

    Are there any other solutions before i go for reinstall?

    Thanks & Regards,

    Constantin

    Monday, April 18, 2011 9:08 AM
  • Hi Yichun,

    I had the same problem and could solve it by upgrading Windows Installer to the Version 4.5.

    Thank you for your help.

    Yuri Iunin

     

     

    Friday, January 27, 2012 1:49 PM
  • Good Day Yichun:

    Let me take this opportunity to express my apprciation for your helpful recommendation to upgrade Windows Installer to address this problem.  I was experiencing much frustration with the .net framework installation on my XP system until I came accross your post on this site.  The problems have all been eliminated, thanks to you!

    I want to encourage you to keep up the good work.  There are others such as I who couldn't navigate the OS without kind assistance from such as you.

    Sincerely,

    vpsanchez

    Wednesday, June 20, 2012 7:17 PM
  • Hi Yichun,

    I wanted to post my issue here since you seem to have some knowledge on framework install issues.  below is a thread I posted regarding an installation issue.  Can you please help me resolve it.  I tried installing Win Installer 4.5 but didn't help.  Tried cleanup, validation check re installation, but no luck...

    thanks

    Hi,

    I am trying to install .netframework 3.5 sp1 on a Windows 2003 server, but it gives an error when framework 2 sp2 installs.  I have update the Windows Installer to v 4.5, tried to install each of the .net version separately but no luck.  any help will be appreciated.  below is the install log;

    === Verbose logging started: 7/16/2013  0:32:51  Build type: SHIP UNICODE 4.05.6001.00  Calling process: c:\e866f2d1520eae756f\setup.exe ===
    MSI (c) (D0:7C) [00:32:51:312]: Resetting cached policy values
    MSI (c) (D0:7C) [00:32:51:312]: Machine policy value 'Debug' is 0
    MSI (c) (D0:7C) [00:32:51:312]: ******* RunEngine:
               ******* Product: c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (c) (D0:7C) [00:32:51:312]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (D0:7C) [00:32:51:312]: Grabbed execution mutex.
    MSI (c) (D0:7C) [00:32:51:312]: Cloaking enabled.
    MSI (c) (D0:7C) [00:32:51:312]: Attempting to enable all disabled privileges before calling Install on Server
    MSI (c) (D0:7C) [00:32:51:312]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (D4:FC) [00:32:51:343]: Running installation inside multi-package transaction c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi
    MSI (s) (D4:FC) [00:32:51:343]: Grabbed execution mutex.
    MSI (s) (D4:F0) [00:32:51:343]: Resetting cached policy values
    MSI (s) (D4:F0) [00:32:51:343]: Machine policy value 'Debug' is 0
    MSI (s) (D4:F0) [00:32:51:343]: ******* RunEngine:
               ******* Product: c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi
               ******* Action:
               ******* CommandLine: **********
    MSI (s) (D4:F0) [00:32:51:343]: Machine policy value 'DisableUserInstalls' is 0
    MSI (s) (D4:F0) [00:32:51:343]: File will have security applied from OpCode.
    MSI (s) (D4:F0) [00:32:51:500]: SOFTWARE RESTRICTION POLICY: Verifying package --> 'c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi' against software restriction policy
    MSI (s) (D4:F0) [00:32:51:500]: SOFTWARE RESTRICTION POLICY: c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi has a digital signature
    MSI (s) (D4:F0) [00:32:51:593]: SOFTWARE RESTRICTION POLICY: c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi is permitted to run at the 'unrestricted' authorization level.
    MSI (s) (D4:F0) [00:32:51:593]: End dialog not enabled
    MSI (s) (D4:F0) [00:32:51:593]: Original package ==> c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi
    MSI (s) (D4:F0) [00:32:51:593]: Package we're running from ==> c:\WINDOWS\Installer\e11fd.msi
    MSI (s) (D4:F0) [00:32:51:593]: APPCOMPAT: looking for appcompat database entry with ProductCode '{B508B3F1-A24A-32C0-B310-85786919EF28}'.
    MSI (s) (D4:F0) [00:32:51:593]: APPCOMPAT: no matching ProductCode found in database.
    MSI (s) (D4:F0) [00:32:51:593]: MSCOREE not loaded loading copy from system32
    MSI (s) (D4:F0) [00:32:51:593]: Machine policy value 'TransformsSecure' is 1
    MSI (s) (D4:F0) [00:32:51:593]: Note: 1: 2262 2: File 3: -2147287038
    MSI (s) (D4:F0) [00:32:51:593]: Note: 1: 2262 2: MsiFileHash 3: -2147287038
    MSI (s) (D4:F0) [00:32:51:593]: File will have security applied from OpCode.
    MSI (s) (D4:F0) [00:32:52:093]: Original patch ==> c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\PreXP.msp
    MSI (s) (D4:F0) [00:32:52:093]: Patch we're running from ==> c:\WINDOWS\Installer\e11fe.msp
    MSI (s) (D4:F0) [00:32:52:093]: SOFTWARE RESTRICTION POLICY: Verifying patch --> 'c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\PreXP.msp' against software restriction policy
    MSI (s) (D4:F0) [00:32:52:093]: SOFTWARE RESTRICTION POLICY: c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\PreXP.msp has a digital signature
    MSI (s) (D4:F0) [00:32:52:109]: SOFTWARE RESTRICTION POLICY: c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\PreXP.msp is permitted to run at the 'unrestricted' authorization level.
    MSI (s) (D4:F0) [00:32:52:109]: File will have security applied from OpCode.
    MSI (s) (D4:F0) [00:32:52:109]: Note: 1: 1310 2: 32 3: c:\WINDOWS\Installer\e11ff.msp
    MSI (s) (D4:F0) [00:32:52:109]: Unable to create a temp copy of patch 'c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\CLR.msp'.
    The system cannot open the device or file specified.
    MSI (s) (D4:F0) [00:32:52:109]: Product: Microsoft .NET Framework 2.0 Service Pack 1 - Update '{125F0ACC-D3FC-402B-8D96-27F6E46D00D5}' could not be installed. Error code 1635. Additional information is available in the log file C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\dd_NET_Framework20_Setup764D.txt.

    MSI (s) (D4:F0) [00:32:52:109]: Windows Installer installed an update. Product Name: Microsoft .NET Framework 2.0 Service Pack 1. Product Version: 2.1.21022. Product Language: 0. Update Name: {125F0ACC-D3FC-402B-8D96-27F6E46D00D5}. Installation success or error status: 1635.

    MSI (s) (D4:F0) [00:32:52:109]: Note: 1: 1708
    MSI (s) (D4:F0) [00:32:52:109]: Product: Microsoft .NET Framework 2.0 Service Pack 1 -- Installation failed.

    MSI (s) (D4:F0) [00:32:52:109]: Windows Installer installed the product. Product Name: Microsoft .NET Framework 2.0 Service Pack 1. Product Version: 2.1.21022. Product Language: 0. Installation success or error status: 1635.

    MSI (s) (D4:F0) [00:32:52:109]: Attempting to delete file c:\WINDOWS\Installer\e11fe.msp
    MSI (s) (D4:F0) [00:32:52:109]: MainEngineThread is returning 1635
    MSI (s) (D4:FC) [00:32:52:218]: No System Restore sequence number for this installation.
    This patch package could not be opened.  Verify that the patch package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer patch package.
    c:\e866f2d1520eae756f\wcu\dotnetframework\dotnetfx20\netfx20a_x86.msi
    MSI (s) (D4:FC) [00:32:52:218]: User policy value 'DisableRollback' is 0
    MSI (s) (D4:FC) [00:32:52:218]: Machine policy value 'DisableRollback' is 0
    MSI (s) (D4:FC) [00:32:52:218]: Incrementing counter to disable shutdown. Counter after increment: 0
    MSI (s) (D4:FC) [00:32:52:218]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (D4:FC) [00:32:52:218]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
    MSI (s) (D4:FC) [00:32:52:218]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (D4:FC) [00:32:52:218]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress 3: 2
    MSI (s) (D4:FC) [00:32:52:218]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (s) (D4:FC) [00:32:52:218]: Restoring environment variables
    MSI (c) (D0:7C) [00:32:52:218]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
    MSI (c) (D0:7C) [00:32:52:218]: MainEngineThread is returning 1635
    === Verbose logging stopped: 7/16/2013  0:32:52 ===

    Tuesday, July 16, 2013 2:18 AM