none
Set language application LightSwitch SilverLight RRS feed

  • Question

  • Hi all,

    Is it possible to set the language in my application (LightSwitch SilverLight)?

    Because I set in the project the properties, but when it runs, the application is in language default (English).

    It possible set a language in what you want?

    Thank you!

    Ale

    Friday, July 26, 2013 4:00 PM

Answers

All replies

  • Hi Ale,

    For a Silverlight client that’s localized into multiple languages, the active Windows language pack on your machine determines which language will appear. For an HTML client that’s localized into multiple languages, the browser language setting determines which language will appear. Changing the Default Language property only tells LightSwitch to check for that language pack or browser setting, and if found display in that language. It only applies to default UI strings; any strings that you provide yourself must be localized. See Walkthrough: Localizing a LightSwitch Application

    Hope this helps,


    Steve Hoag Microsoft aka the Lights Witch (IEnumerable of Newt)


    Friday, July 26, 2013 10:30 PM
    Moderator
  • Hi Steve,

    your response is interesting.

    But, in my project in SilverLight, I don't have the screens.

    I have only the project in SilverLight, for management the users and passwords of my application.

    But, when i watch the screen, automatically, for management the users, the language is English.

    It possible set another language?

    Thanks, best regards.

    Ale

    Monday, July 29, 2013 7:14 AM
  • What version of LightSwitch are you using? If you are using VS 2012, have Update 3 installed, and upgraded your project, then you are likely seeing the issue as reported here: Language bug in VS2012 Update 3 To LS Team.

    Justin Anderson, LightSwitch Development Team

    Monday, July 29, 2013 9:15 AM
    Moderator
  • Hi Justin,

    I use the VS 2012 and I Installed already the Update 3.

    Tuesday, July 30, 2013 7:28 AM
  • I believe you have the same problem as described in the thread that I've linked to in the above post. Please use the workaround that Beth has provided and follow that post for updates. I'm sure we will announce the availability of the fix in a more general manner as well.

    Justin Anderson, LightSwitch Development Team

    Tuesday, July 30, 2013 8:22 AM
    Moderator
  • Thanks for the advice.
    Best regards

    Ale

    Tuesday, July 30, 2013 10:28 AM