locked
Visual Studio 2013 Preview gets really laggy and slow RRS feed

  • Question

  • This weird problem came out of nowhere. I started VS2013, and it started to get really slow. Whenever I do something (write code, build, run etc.), VS gets really slow, hogging all CPU resources. If I let it be still, it'll get normal in about a minute. If I write some new code, however, the slowness returns.

    I'm running Windows 8.1 Preview x64 with Visual Studio Ultimate 2013 Preview. I have no extensions installed besides the ones that come with VS. I tried resetting all settings and uninstalling and reinstalling VS, but it didn't help.

    Wednesday, August 14, 2013 11:49 AM

Answers

  • This weird problem came out of nowhere. I started VS2013, and it started to get really slow. Whenever I do something (write code, build, run etc.), VS gets really slow, hogging all CPU resources. If I let it be still, it'll get normal in about a minute. If I write some new code, however, the slowness returns.

    I'm running Windows 8.1 Preview x64 with Visual Studio Ultimate 2013 Preview. I have no extensions installed besides the ones that come with VS. I tried resetting all settings and uninstalling and reinstalling VS, but it didn't help.

    To resolve this ussue, only change de source control to none. Problem with git. 
    • Edited by flavio.adias Thursday, August 22, 2013 3:32 AM
    • Marked as answer by Manabreak Friday, August 23, 2013 6:44 AM
    Thursday, August 22, 2013 3:28 AM

All replies

  • Hello,

    To get the issue confirmed and diagnose by product team, would you please create connect report for it? You will get email notification for update.http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx, if you submit it, you could share us the link here, so we could know the latest information from the Product team expert. And I will help you to vote it.

    Best regards,


    Amanda Zhu
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, August 15, 2013 9:46 AM
  • Does this occur with multiple project types? Are any of these projects under source control? Did this performance lag happen from day 1?

    Thanks,


    Ed Dore

    • Proposed as answer by flavio.adias Thursday, August 22, 2013 3:24 AM
    • Unproposed as answer by Manabreak Friday, August 23, 2013 6:45 AM
    Monday, August 19, 2013 4:53 PM
  • This weird problem came out of nowhere. I started VS2013, and it started to get really slow. Whenever I do something (write code, build, run etc.), VS gets really slow, hogging all CPU resources. If I let it be still, it'll get normal in about a minute. If I write some new code, however, the slowness returns.

    I'm running Windows 8.1 Preview x64 with Visual Studio Ultimate 2013 Preview. I have no extensions installed besides the ones that come with VS. I tried resetting all settings and uninstalling and reinstalling VS, but it didn't help.

    To resolve this ussue, only change de source control to none. Problem with git. 
    • Edited by flavio.adias Thursday, August 22, 2013 3:32 AM
    • Marked as answer by Manabreak Friday, August 23, 2013 6:44 AM
    Thursday, August 22, 2013 3:28 AM
  • This weird problem came out of nowhere. I started VS2013, and it started to get really slow. Whenever I do something (write code, build, run etc.), VS gets really slow, hogging all CPU resources. If I let it be still, it'll get normal in about a minute. If I write some new code, however, the slowness returns.

    I'm running Windows 8.1 Preview x64 with Visual Studio Ultimate 2013 Preview. I have no extensions installed besides the ones that come with VS. I tried resetting all settings and uninstalling and reinstalling VS, but it didn't help.

    To resolve this ussue, only change de source control to none. Problem with git. 
    This was the solution. Thanks a lot!
    Friday, August 23, 2013 6:44 AM
  • @flavio.adias  Thanks! You saved my day (or a few days - literally)
    • Edited by pvasek Tuesday, January 14, 2014 8:19 PM
    Tuesday, January 14, 2014 8:18 PM
  • kudos to you sir
    Monday, January 27, 2014 12:01 AM
  • How do you change source control to "none"


    Thomas Hall

    Tuesday, June 24, 2014 8:55 PM
  • How do you change source control to "none"


    Thomas Hall

    Go to Tools -> Options -> Source Control -> Plug-In Selection.
    Wednesday, November 12, 2014 8:21 AM
  • I tried many different things from this site and also form other blogs. Nothing was helping. My issue was that I was creating my projects on my folder on my company's LAN. Once I moved my project to my computer's drive I saw a very significant improvement to the performance. Opening a file took me about 30 seconds, now it takes less than a second. I have no issues opening the files on the network through windows explorer. This issue impacted even compiling.

    Aude

    Thursday, May 7, 2015 1:49 PM
  • Thank you kind Sir, for saving me.
    Monday, August 10, 2015 7:40 PM
  • We are in Azure platform and we are currently experiencing this issue with VS2013 installed. Source control is already set to NONE but same issue.

    Thursday, July 28, 2016 1:51 PM