none
can't find bin\debug\filename.xml RRS feed

  • Question

  • I'm a begginer

    I have Windows XP SP 3

    Visual Studio 2005 ver 8.0.50727.762

    .net framework 2.0.50727 sp2

    I have the source code of a system called PointsSystem

    I start debugging PointsSystem.sln and get error: Could not find file bin\debug\PointsSystem.xml

    and it is there, in that folder

    this system was devoloped by a programmer who sent me the source code, want to check if i would be able to make changes on a form but i cant even debug the original code

    I email the programmer and he has no idea, he sent the .xml file, I overwrite it and same error, he told me to delete it and see if it would recreate by itself and it didn't recreate and I get the same error, now it's true since I deleted it

    any idea?

    thanks!

     

     

     

    Wednesday, February 23, 2011 1:46 AM

Answers

  • thanks! Milo

    it worked, don't get the error anymore

    1st I turned off "show all files" on original proyect

    then on the new project I "add existing item" one by one

    then on the new project I right click references>add reference>browse to original project and added one by one

    I ran in debug and No Errors !!!! 

    • Marked as answer by Myrna LC Saturday, February 26, 2011 10:16 PM
    Saturday, February 26, 2011 10:15 PM

All replies

  • Hi Myrna,

     

    Would you please create a new project and copy all the source files in it.

     

     

    Best Regards,

    Thursday, February 24, 2011 10:32 AM
  • Hi Milo

    just to let you know that before I got your answer, a coworker also tried to ran in debug and he get the same error, he tried at home with his laptop where he has another version of Visual Studio and also got the same error

    he then asked a friend to try to ran it in his laptop and also he gets the same error

    so far in 4 differentes computers we get the same error

    i emailed the developer and  he doesn't have any problems

    so what is missing in our computers?

    anyway when creating a new project as you suggest, what about folders: bin, My project, obj should I also copy them?

    thanks!

     

    Thursday, February 24, 2011 7:14 PM
  •  

    Hi Myrna,

     

    This issue is about the file ’path, and you ensure that both the PointsSystem.xml file and the .exe file are in the same folder. You may change the source code about reading the path of the .xml file, something like this:

     

    .ReadXml(“PointsSystem.xml”)    à  .ReadXml(Application.StartupPath+@"/PointsSystem.xml");

     

    If it still exist this error, please create a new project according to the following steps:

     

    1.        Create a new project and open the old one to compare with two projects in “Solution Explorer” window of the Visual Studio.

    2.        Right-click the new project name and choose “Add” and select “Existing Item” option.

    3.       Add all the files in the old project fold which the new project did not exist.

    4.       Copy the .xml file to the new project\bin\Debug directory. Then built the new project.

     If you still need my help and trust me, you could send the source code to my personal mail (rqmyl@hotmail.com). I will fix it as soon as possible.

     

    Best Regards,

    Milo

    Friday, February 25, 2011 2:45 AM
  • thanks! Milo

    it worked, don't get the error anymore

    1st I turned off "show all files" on original proyect

    then on the new project I "add existing item" one by one

    then on the new project I right click references>add reference>browse to original project and added one by one

    I ran in debug and No Errors !!!! 

    • Marked as answer by Myrna LC Saturday, February 26, 2011 10:16 PM
    Saturday, February 26, 2011 10:15 PM
  • The solution i'll use in this case will be to check for any entry in .csproj file for the project. Before that keep a backup of that file. Locate for the entry "bin\debug\PointsSystem.xml", delete it and then save the file. rebuild the project.. It's done...

    All The Best

    Friday, August 2, 2019 4:24 PM