none
Cannot start debugging because the debug target ... is missing RRS feed

  • Question

  • Using VS 2005 Pro / Visual Basic.

    "Build" --> an .exe appears in /bin. (Build successful; no errors or warnings.)

    Right after that, F5 --> an error message "Visual Studio cannot start debugging because the debug target ... is missing...".  Checking: an .exe misteriously disappeared(!) from /bin.

    Immediately after that F5 -> application runs, an .exe appears in /bin.  (Occasionally, would take several more F5's.)

    Anybody has an idea what is happening?

    Y.Fradkin

    Thursday, August 10, 2006 8:23 PM

Answers

  • Hi all

    Seems Like I have found the Solution, Here is what you do........

    Open solution  in V2005, then go to Project -> Properties.

    In this, Go to build, and then check the "Output" section at the bottom End

    Browse for correct Directory Path. "Default is Bin\debug" you may want to change it where the actual exe / dll is.

    this has solved my problem as my Build environment was keeping the Target Exe Somewhere else and the code somewhere else..

    Let me Know

    Amol Wankhede

    Saturday, September 16, 2006 6:39 PM

All replies

  • Dude,

    I am having te same problem....did you get any help from any body

    Please let me know

    Thanks

    Amol

    Thursday, August 24, 2006 1:04 AM
  • No help yet...  I wonder if we are the only two with this problem.
    Thursday, August 24, 2006 1:12 AM
  • Have you guys solved this?  I am wasting valuable time.  I will post if I find an answer.
    Thursday, September 7, 2006 4:04 PM
  • That makes three of us...  no solution yet.
    Saturday, September 16, 2006 1:48 AM
  • Hi all

    Seems Like I have found the Solution, Here is what you do........

    Open solution  in V2005, then go to Project -> Properties.

    In this, Go to build, and then check the "Output" section at the bottom End

    Browse for correct Directory Path. "Default is Bin\debug" you may want to change it where the actual exe / dll is.

    this has solved my problem as my Build environment was keeping the Target Exe Somewhere else and the code somewhere else..

    Let me Know

    Amol Wankhede

    Saturday, September 16, 2006 6:39 PM
  • I think this is the one I solved by changing the start up object.  Right click on the project in Sol Ex, and choose properties.  Then change the startup object.
    • Proposed as answer by Ade1970 Thursday, May 15, 2014 5:27 AM
    Monday, October 2, 2006 3:05 PM
  • I am having the same trouble as well. Please let me know if you have a solution.
    Wednesday, November 8, 2006 2:45 PM
  • You have to remove all the errors in your application for it to compile as Debug or release
    Saturday, December 16, 2006 9:05 PM
  • One of the lines of code in your application is keeping your application from compiling either in debug or release. check the error list for more info. Get rid of the error and your applications should automatically compile an exe when you click "Start Debug".
    Saturday, December 16, 2006 9:17 PM
  • I had the same problem and the real solution was embarrassingly easy:

    If, in your project, Visual Studio has never successfully compiled the program (before finding the first bug), you will get this error. What I did was remove all offending code (in my case, leaving just a simple button1_Click with no code). Run/Compile the code one time; exit the running program, and this message goes away.

    The Compiler builds various directories and files on a first successful compile and these are used by the debugger.  I am now recommending with all new projects, define the form, compile, close, and then begin coding.
    • Proposed as answer by Harry_77 Monday, May 11, 2009 3:01 AM
    Monday, June 18, 2007 3:57 AM
  • This did not work.  When I updated to 2005 express '05 addition changed this to ...vhost.exe and the description in properties is vhost.exe .  I tried to change the name to just and .exe but it still show vhost.exe in the properties description.  It is this way for all my files that had worked in '04 MS Visual C# 

    The warning tells me to change the OutputPath and AssemblyName properties.  Where can I do this?  I tried the above post and it did not work. 
    Saturday, May 9, 2009 3:19 AM
  • This works!!! Another gentleman said something to this effect except withour the better description.  The code errors were causing this code error.  The issue I said was because it was the first time I ran (built/debugged) this code in the new 05 express edition.  I just commented out the error(s) in my code that the debugger displayed and it worked.
    Monday, May 11, 2009 3:04 AM
  • I solved the problem by changing the start up project
    Wednesday, August 26, 2009 2:22 PM
  • I too had this issue, and it turned out the path to the external program was wrong.  When I corrected it, the error went away.  To correct the issue: from the project property, selected Debug, changed the 'Start external program'.  I am using Visual Studio 2008 Professional,
    • Proposed as answer by Trdough Wednesday, November 2, 2011 4:31 AM
    Monday, September 14, 2009 1:40 PM
  • Turning off "option strict" in properties fixed this for me. All the other options above did not.
    Friday, September 18, 2009 3:13 AM
  • you are really a good boy! i can debug it now,thank you!
    Sunday, December 13, 2009 3:15 PM
  • Well I am using VS2008 and still unable to find the solution of this problem. Can any one tell me step by step solution of this problem in VS2008.. ? Thanks...
    Saturday, January 30, 2010 9:48 AM
  • FASTianCadet, are you creating a console application?  If so, you'll need to change your startup object.  I was having what I believe is the same problem and that was my solution. 

    Cheers.
    Saturday, January 30, 2010 5:16 PM
  • WEll yeah I am creating Console Application. Can you tell me How do I change startup object?

    Thanks!!
    Saturday, January 30, 2010 6:42 PM
  • Had the same issue with a solution started being just as a Class Library and after was added a WPF Application project. When I set the WPF Applicaiton as the startup project.

    My workaround was:
    1. Resetting the Class Library project as the start project;
    2. Rebuild the WPF Application, thus creating the .exe file;
    3. Set the WPF Application as startup project.

    And all ran as expected. I guess the IDE fell a sleep in the first startup change.

    If any one has FASTinaCADET question, to change the solution's startup project in VS2008 there are two options:
    1. Right-click the desired project in Solution Explorer and choose 'Set as StartUp Project'
    2. In Solution Properties (accessed by right-click Solution and select 'Properties'), navigate in the left side tree to 'Common Properties/Startup Project' where can not only select the starup project but also multiple starup projects and order.

    Bigsby, Lisboa, Portugal
    O que for, quando for, é que será o que é...
    Wenn ist das Nunstruck git und Slotermeyer? Ja! ... Beiherhund das Oder die Flipperwaldt gersput!
    http://bigsby.eu
    Thursday, March 4, 2010 7:35 AM
  • I also received this message and the solution for me was to go into Build -> Configuration Manager and set the value in the Platform column for the problem project to the same as my other projects. After I did this I could build and run a Release version with the previously offending project as the Start project.

    Andrew.

    • Proposed as answer by Wayne Arly Wednesday, November 23, 2011 3:47 PM
    Thursday, July 8, 2010 10:30 PM
  • Same problem here.  Fixed in the IDE settings (not the project) under Tools->Options->Projects and Solutions->Build and Run

    Theres a list under "On Run, when projects are out of date:"

    Select:  "Always Build"

     

     

     

    Wednesday, November 17, 2010 4:13 PM
  • Dude just check all the project folder if its red-only. i had the problem but some files are set to be like that forever so u can't undo it
    Thursday, August 11, 2011 7:48 AM
  • same problem... fixed by check "Enable unmanaged code debugging"
    eyal k
    Tuesday, August 23, 2011 1:17 PM
  • right click on the project->Clean, and build the project again.

    Monday, October 3, 2011 5:37 AM
  • I have encountered this issue too when i debugging a WPF project, after some investigation i installed BlendWPFSDK_en.msi on my host it resolved, if somebody gets same issue you can try it, hope it help
    Tuesday, December 6, 2011 3:10 AM
  • conexao = "Data Source=dell-pc/sqlexpress;Initial Catalog=pedido;Integrated Security=True";

     

    the error is in the bar after the data source

     

    conexao = "Data Source=dell-pc;sqlexpress;Initial Catalog=pedido;Integrated Security=True";

    Tuesday, January 10, 2012 9:39 PM
  • Another thing that is worth checking is to check solution configuration (righ-click on solution > properties > Configuration Properties) to ensure the project is checked to build in the configuration you are trying to build.


    Application Developer
    Thursday, January 19, 2012 3:33 AM
  • For those of you that are using express editions of Visual Basic, they do not allow you to edit the start-up location path for the executable you are designing your program for. A non-express version of Visual Basic should be used to change the respective field by going to:

    Project -> Project Properties -> Debug Tab.

    This option does not exist in the the Express edition, God knows why... Hope that helps.

    Thursday, January 19, 2012 4:40 PM
  • Using VS 2005 Pro / Visual Basic.

    "Build" --> an .exe appears in /bin. (Build successful; no errors or warnings.)

    Right after that, F5 --> an error message "Visual Studio cannot start debugging because the debug target ... is missing...".  Checking: an .exe misteriously disappeared(!) from /bin.

    Immediately after that F5 -> application runs, an .exe appears in /bin.  (Occasionally, would take several more F5's.)

    Anybody has an idea what is happening?

    Y.Fradkin

    when you have an error in your code this problem may appears

    close ur VS then open again

    write a very simple code and run

    the problem must disapeare

    i think that some specific error  in programing (not common error) should cause this problem


    Monday, May 14, 2012 5:41 PM
  • Thanks very much!!!!!! everybody , if we meet together i treat you beer!!!! of course . without in

    restriction!

    In the end, i was so many many times try it . my solution is to modify project-> project properities

    and Choose Build section -> Output path modify-> obj\x86\Debug\ : this default path is bin\Debug !!

    so you modify following this (and same problem for me) Good luck and God bless you !!!!

    thanks you !!!!!!!!

    written by ChoI 

    Saturday, September 29, 2012 3:34 PM
  • Check if your assembly name has spaces in it.

    Windows 7 Libraries: The best way to lose something since filing cabinets were all the rage!

    Friday, June 7, 2013 2:18 AM
  • When you attempt to debug your program you are calling the Visual Studio debugger to run your code.  However, your project instance is attempting to call either an old debug version from a previous version of Visual Studio or is not pointing to a correct debug exe.

    We need to update the location of the debug exe to the current version of Visual Studio's 'devenv.exe'.

    How to solve:

    1. Right click on the start up project in solution explorer.
    2. Select 'properties'.
    3. Choose the 'Debug' tab.
    4. On the debug form under the 'Start Action' section, change the 'Start external program' file location and set to the current version of Visual Studio 'devenv.exe'.

    Under the default installation this should be:

    C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\devenv.exe

    Where 'Microsoft Visual Studio 12.0' is Visual Studio 2013.

    Replace this with 'Microsoft Visual Studio 11.0' for Visual Studio 2012.

    Replace this with 'Microsoft Visual Studio 10.0' for Visual Studio 2010.

    And so on...

    Monday, December 16, 2013 1:00 PM
  • Using VS 2005 Pro / Visual Basic.

    "Build" --> an .exe appears in /bin. (Build successful; no errors or warnings.)

    Right after that, F5 --> an error message "Visual Studio cannot start debugging because the debug target ... is missing...".  Checking: an .exe misteriously disappeared(!) from /bin.

    Immediately after that F5 -> application runs, an .exe appears in /bin.  (Occasionally, would take several more F5's.)

    Anybody has an idea what is happening?

    Y.Fradkin

    project/properties/ compile browser C:\Users\USER\Documents\Visual Studio 2015\Projects\\obj\Debug

    and select ... work test LOL

    Monday, January 25, 2016 4:36 PM
  • Harry_77 is right.

    After deleted my Button i face the same issue. And after removing Button icon  References from Project > properties > Resources - Solved the problem.

    Monday, April 25, 2016 9:45 AM
  • Im using VS Community 2017 any help?


    jacobscraig

    Wednesday, December 19, 2018 3:19 AM