none
Visual Studion 2010 Disable Script Debugging RRS feed

  • Question

  • I know this Forum is for VS 2008 - but maybe someone can help or direct me to another forum. My question is quite simple. While Script Debugging is very helpfull as long as one writes JS, there are some times where it is just a big performance disadvantage. Does anyone know a way to turn it off?

    For VS 2008 there was this reg key:

    reg add HKLM\SOFTWARE\Microsoft\VisualStudio\9.0\AD7Metrics\Engine\{F200A7E7-DEA5-11D0-B854-00A0244A1DE2} /v ProgramProvider /d {4FF9DEF4-8922-4D02-9379-3FFA64D1D639} /f

    Is there somethin similar in 2010? I have tried with the project options but that did not help
    Tuesday, February 23, 2010 9:38 AM

Answers

All replies

  • Hi,

     

    I am not sure if there is a similar registry key for dev10.

    What you can try to do is:

    -          disable JIT debugging for script in VS (Tools ->Options ->Debugging ->Just-In-time -> Script)

    -          and  launch you app using start without debugging (Ctrl +F5). If you still want to debug , but not script code, you can attach to your exe and specify the engine you want (managed, native…)

     

    hope that this helps,

    Alina

     

    Tuesday, February 23, 2010 9:53 PM
    Moderator
  • Hi,

     

    You should run the cmd:

    reg add HKLM\SOFTWARE\Microsoft\VisualStudio\10.0\AD7Metrics\Engine\{F200A7E7-DEA5-11D0-B854-00A0244A1DE2} /v ProgramProvider /d {4FF9DEF4-8922-4D02-9379-3FFA64D1D639} /f

     

    (if using Web Dev Express SKU, modify the key by replacing “VisualStudio” with “VWDExpress”)

     

    hope that this helps,

    Alina

    • Marked as answer by Alexander P Friday, February 26, 2010 8:05 AM
    • Unmarked as answer by Alexander P Friday, February 26, 2010 4:25 PM
    • Proposed as answer by thomashagstrom Monday, May 27, 2013 1:01 PM
    Thursday, February 25, 2010 6:54 PM
    Moderator
  • Also, can you give us more details on why you consider it a big performance disadvantage? What is the scenario you are trying to debug?
    Alina

    Thursday, February 25, 2010 10:23 PM
    Moderator
  • I am using a lot of AJAX Controls in most of the pages and sometimes need to jump through 3 or more pages until I come to the page that I actually want to debug (most of the time is C# that I am debugging). On the way to my target page I see a lot of Script Documents info expanding and colapsing in Solution Explorer - script code that I have not written and also dont want to debug because it is code from my control manufacturer compiled into the assemblies of my controls - I can not even change it so there is no need to see its beeing executed. This expanding and colapsing, even if there is no beakpoint slows donw page execution - so with script debugging it sometimes takes me twice the time or more than that to get to my code.

    I agree script debugging is very valuable for certain times when I am really writing js and want to debug that - but most of the time it only slows down my C# debugging experience. Multiplied by the thousnd times I press F5 during one day this is a lot of wasted time for (script) code I can not even change. The best solution would be a switch in one of the tool bars to turn it on of off.

    I have also checked your propsed solution - it does not help - but thanks anyway
    Friday, February 26, 2010 4:38 PM
  • Thank you for the feedback!

     

    The workaround I proposed should work for VS and IE8. Also, if you are running on a x64 bit computer, you should run the 32-bit command prompt: http://blogs.msdn.com/greggm/archive/2009/04/06/disabling-script-debugging-in-vs-2008-ie8.aspx

     

    hope that this helps,

    Alina

    • Marked as answer by Alexander P Saturday, February 27, 2010 11:06 AM
    Friday, February 26, 2010 7:06 PM
    Moderator
  • Neither of these solutions worked for me.  I'm getting JScript runtime errors that cause VS2010 Ultimate to force a dialog box and suspend page execution until I click them.  Note, the browser never complains about it and (after I click Continue 8-10 times) the page renders and functions correctly.  It is breaking in "myfile.aspx [dynamic]" (what is this "dynamic" bit, anyway?) on a line that has nothing other than "<td>" on it.  HTML after this line in the source file is completely truncated.

    This is highly frustrating because there's not even a visible javascript error happening at all, and no browser I test ever complains about anything.

    I've tried both the registry hack (which I added to our company's standard developer image for VS2008) and I have unchecked "Script" in the Tools -> Options -> Debugging -> Just-In-Time menu.

    Any advice would be much appreciated as my only alternative right now is to run the code without a debugger attached at all.

    And no, I'm not installing a Silvertrash debugger to disable a javascript debugger.

    Thursday, July 8, 2010 9:24 PM
  • Not to re-open an old thread, but has this workaround changed since VS 2010 SP1, I had applied this patch to the registry and it was working successfully, however after installing SP1 script debugging seems to be active again.
    • Proposed as answer by Mark Phillips Wednesday, July 6, 2011 9:58 PM
    • Unproposed as answer by Mark Phillips Wednesday, July 6, 2011 9:58 PM
    Wednesday, March 23, 2011 4:26 PM
  • I have to just say that this bug is really careless and should be fixed immediately by Microsoft. 

    No one should have to tinker  with the registry to enable and disable javascript. 

    This was probably a conscious decision, to force developers to download and start using Silverlight.

    Wednesday, July 6, 2011 10:03 PM
  • Is there any answer on this? (It's been over a year).

    Visual Studio 2010 SP1, Windows 7 64 bit.

    Thursday, November 1, 2012 5:26 PM
  • I need a fix to this also. 
    Monday, November 5, 2012 11:57 PM