none
Database project - Deploy Solution and Deploy DbName do nothing from the menu

    Question

  • Hi everybody,

    I have the latest VS 

    Microsoft Visual Studio Enterprise 2017 
    Version 15.5.2
    VisualStudio.15.Release/15.5.2+27130.2010
    Microsoft .NET Framework
    Version 4.7.02556

    Installed Version: Enterprise

    ------------------------------------------------------

    I can click F5 in my Database Project and the solution is being re-build and then deployed. However, trying the same options from the Build menu does absolutely nothing. Re-build and Clean work, but Deploy or Deploy DbName does nothing and it used to work before.

    Is it a new VS bug or I'm missing something?

    Thanks in advance.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Wednesday, January 03, 2018 9:46 PM

Answers

All replies

  • Hi Naomi N,

    Please make the checkbox shown below is unchecked:

    This setting will affect the deploy action. When this is checked, the database project, which is not the startup project builds but does not deploy on Run/Debug. When this is unchecked, the database project builds and deploys as expected.

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, January 04, 2018 2:57 AM
  • I don't think this is it. When I click F5 (green button), my solution correctly builds and deploys regardless of this setting.

    However, when I try to access that same option from the Menu (from the Build/Deploy), nothing happens. It doesn't deploy, but 'Clean' and 'Rebuild' work.


    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Thursday, January 04, 2018 3:06 AM
  • You're right. It does nothing when we click it.

    I've reported it to VS developing team:

    https://developercommunity.visualstudio.com/content/problem/176692/database-visual-studio-2017-version-155.html

    and we'll wait for their response, you could go and vote it.

    Thanks for your findings.

     

    Regards,

    Fletcher   


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, January 04, 2018 8:51 AM
  • Thanks a lot, I voted this item and will wait resolution. It's not a big issue, but I'm used to use the menu as well as green button.

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Thursday, January 04, 2018 1:23 PM
  • BTW, it is still not working even with today's update (15.8.7)

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Thursday, October 11, 2018 8:48 PM