none
VS 2015 Debugger - Can't debug project (but can in VS2015) RRS feed

  • Question

  • I have an ASP.NET application that I've been working with in VS 2013. I've just installed VS 2015. When I debug my application in VS 2013 it works.  When I try to debug in VS 2015 I receive the error message "Unable to start debugging on the web server.  IIS does not list a web site that matches the launched URL." 

    Typically when I receive this message I can just close out VS and reopen and it will start working again.  This is not the case in VS 2015.  I have closed the project, then opened and debugged successfully in VS 2013.  Then I close it and try in VS 2015 - same error.

    Any ideas?

    Thanks in advance for the guidance!!


    Nikki Veit

    Wednesday, September 16, 2015 2:22 PM

Answers

  • Hi Nikki Veit,

    Do you mean that you install the VS2013 and VS2015 in the same machine?

    How about opening the project in VS2015 as the admin?

    If you create a new simple web app in VS2013, and then update it to VS2015, how about the result?

    If a simple app worked well, maybe it is related to this specific app.

    >>Unable to start debugging on the web server.  IIS does not list a web site that matches the launched URL.

    I met this error before which was related to the Use custom server in VS2010, but as far as I know, this option was removed from VS2013. Do you custom Web Servers in your side or others? 

    Reference:

    http://forums.asp.net/t/1585732.aspx?IIS+does+not+list+a+web+site+that+matches+the+launched+URL

    http://blogs.msdn.com/b/webdev/archive/2013/09/11/visual-studio-2013-custom-web-servers-and-owinhost-exe.aspx

    In addition, not debug your app, just run your app with "Start without debugging", could you run it well?

    Maybe you could clean and rebuild your project, and then debug it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by veitn Thursday, September 17, 2015 1:06 PM
    Thursday, September 17, 2015 7:25 AM
    Moderator

All replies

  • Hi Nikki Veit,

    Do you mean that you install the VS2013 and VS2015 in the same machine?

    How about opening the project in VS2015 as the admin?

    If you create a new simple web app in VS2013, and then update it to VS2015, how about the result?

    If a simple app worked well, maybe it is related to this specific app.

    >>Unable to start debugging on the web server.  IIS does not list a web site that matches the launched URL.

    I met this error before which was related to the Use custom server in VS2010, but as far as I know, this option was removed from VS2013. Do you custom Web Servers in your side or others? 

    Reference:

    http://forums.asp.net/t/1585732.aspx?IIS+does+not+list+a+web+site+that+matches+the+launched+URL

    http://blogs.msdn.com/b/webdev/archive/2013/09/11/visual-studio-2013-custom-web-servers-and-owinhost-exe.aspx

    In addition, not debug your app, just run your app with "Start without debugging", could you run it well?

    Maybe you could clean and rebuild your project, and then debug it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by veitn Thursday, September 17, 2015 1:06 PM
    Thursday, September 17, 2015 7:25 AM
    Moderator
  • Thank you, Jack!

    Yes, I have both VS 2013 and VS 2015 on the same machine.  It was the admin rights that caused my issue.  I've set the properties so it always opens with Admin rights. 

    I appreciate your thorough response on this!


    Nikki Veit

    Thursday, September 17, 2015 1:17 PM