none
No certificates were found that met all the given criteria RRS feed

  • Question

  • I am using VS 2017 for C++ development of our solution. The project is source controlled by git and built often on our build servers. The build servers sign targets in a "Post-Build Event" on the build servers using our companies certificate. This causes an issue when attempting to build on release on our dev machines. We get this error  "No certificates were found that met all the given criteria" understandably. However when I set the "use In Build" option in "Post-Build Event" to No, I still get the same error. Should this not go away as I am no longer attempting to sign the targets??

     
    Monday, April 30, 2018 12:45 PM

All replies

  • Please always check your certificate expiry date first because most of the certificates have an expiry date. In my case certificate has expired and I was trying to build project.

    To check the certificate expiry, go to the command line, navigate to where your certificate is, then enter certutil -dump mycertificate.pfx

     

    Regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    • Edited by Fletch Zhou Wednesday, May 2, 2018 2:18 AM
    • Proposed as answer by Fletch Zhou Thursday, May 3, 2018 6:24 AM
    Wednesday, May 2, 2018 2:18 AM