.NET Runtime error 1023 RRS feed

  • Question




    I am having an issue with a C# forms application runnning on a new XP Pro SP2 dell laptop. The application runs fine on all other machines.


    I am getting an "...Has encountered an error and needs to close."


    As a test, I created a c# console app that just traps the AppDomain.CurrentDomain.UnhandledException event. The event is never fired. Is this an issue with Dot net versions. I am developing with 2.xx and the new laptop has 3.5 updated.


    Even though I updated the laptop to .NET 3.5 the error indicates it's using 2.0. Here is the application error log entry:


    NET Runtime version 2.0.50727.1433 - Fatal Execution Engine Error (79FFEE24) (80131506)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    I found and followed http://support.microsoft.com/Default.aspx?kbid=913384 for a Fatal Execution Engine Error (7A05E2B3) (80131506)


    But cant find ANYTHING for


    Fatal Execution Engine Error (79FFEE24) (80131506)


     Any suggestions?


    Tuesday, November 27, 2007 6:58 PM

All replies

  • After two days of spinning my wheels...

    I found a way around this issue. Another solution stated a problem with a user/userprofile setup. On a whim, I used the run as command and used USERNAME instead of MACHINE/USERNAME(which the user logs in as) as the account to execute. Well, that worked. Now I need to figure out how to have the app always run in that context.


    Tuesday, November 27, 2007 9:09 PM
  • I have hit the same problem.  Any DotNet based project that I have fails with the same error.  Also, other applications are not running and I think they are DotNet based and hitting the same problem.  I also found alot of information pertaining to errors that were simular, but nothing seemed to fix the issue.

    Have you had any further luck?
    Tuesday, July 29, 2008 9:46 PM
  • Hi,

    you can download the SysInternals Suite, from Microsoft, to inspect your application.

    I've solved a lot of problems using the process monitor application.

    You can download this from:

    fabio_sfernandes@hotmail.com, Brazil, Microsoft Certified Professional
    Tuesday, August 5, 2008 12:15 AM
  • Since you say it works on other systems, I would recommend you uninstall .Net 2 and reinstall it. Also I would reinstall the application. The other scenario is that the hard drive is failing and causing the OS to be flaky. HTH
    William Wegerson (www.OmegaCoder.Com)
    Tuesday, August 5, 2008 12:29 AM
  • Hi,
    Check whether you have the admin rights to your system
    Best Regards, ~ajai
    Wednesday, August 6, 2008 5:30 AM
  • For me it was simple, I unregistered asp.net and register again using aspnet_reg

    Arjun Paudel
    Saturday, October 25, 2008 3:53 AM
  • I had to re-install/upgrade my framework before the problem was fixed.  I was running on .NET 3.0 ... installing .NET 3.5 fixed this IIS problem.
    Thursday, July 15, 2010 8:00 AM