locked
Installation failed with error code: (0x80070643), "Fatal error during installation RRS feed

  • Question

  • I tried everything and it still doesn't work...Even with the  MicrosoftFixIt, NetFrame Cleanup Tool, and even cleaning out the Temp content I did all that above and restart my PC and even cleaned out the registry and nothing works for me its with the same error please help its asap Thank You..
    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x64 Ultimate Edition Service Pack 1
    CommandLine = C:\737ad82965aa105469e48f19\\Setup.exe /x86 /x64
    TimeZone = Pacific Standard Time
    Initial LCID = 1033
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: AlwaysUploaded
    Number of applicable items: 11
    Exe (C:\737ad82965aa105469e48f19\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (C:\737ad82965aa105469e48f19\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
    Exe (C:\737ad82965aa105469e48f19\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (C:\737ad82965aa105469e48f19\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20111116_174622658-MSI_netfx_Core_x64.msi.txt
    Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:17:18).
    Wednesday, November 16, 2011 11:44 PM

Answers

  • Hi Luis,

     

    From your logs:

    [11/21/2011, 11:20:40] Returning IDOK. INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package. Please refer to the setup log for more information. ]

    11/21/11 11:20:39 DDSet_Error: Failed to install assembly C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll. IAssemblyCache->InstallAssembly() returned -2147024891.

    11/21/11 11:20:39 DDSet_Error: Failed to install assembly 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll' because of system error: Access is denied.

    For the error code “-2147024891”, it means “Access is denied”.

     

    First, I recommend you take a look at this page: http://support.microsoft.com/default.aspx?scid=2263996 .

     

    Second, you can try these:

    ·         Click Windows button and type 'regedit' in search bar.

    ·         Click 'regedit' in search results

    ·         Navigate to following registry hive:

    HKLM\Software\Microsoft\Windows\CurrentVersion\Installer

    Check if following registry keys have correct values:

    ·         MsiExecCA32 should end with \Windows\syswow64\msiexec.exe

    ·         MsiExecCA64 should end with \Windows\system32\msiexec.exe

    Re-run setup program after trying troubleshooting steps.

    You can refer to this page: http://blogs.msdn.com/b/varungupta/archive/2010/06/22/troubleshooting-net-framework-4-install-failures.aspx?PageIndex=2

     

    Third, make sure your user account is in Administrators group. To do so: Right-click the installer -> Properties ->Security tab -> add your account with Full control.

     

    If you fail again, please collect a fresh log for further diagnose.

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    • Marked as answer by Alexander Sun Tuesday, November 29, 2011 3:11 AM
    Tuesday, November 22, 2011 8:51 AM

All replies

  • Did you use the standalone installer for .NET Framework 4.0, or the web installer?

    This is the standalone installer:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    This installer is self-contained and *should not* require an internet connection.

    If you will have the problem also using the standalone installer, please run this tool in order to collect some setup log files:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=12493

    upload %TEMP% directory to your skydrive or send me via mail (a-mibrin @ microsoft . com)


    || Michele Brina || Developer Support Engineer || http://blogs.msdn.com/itasupport
    • Edited by Michele Brina Thursday, November 17, 2011 9:28 AM
    • Proposed as answer by Alexander Sun Friday, November 18, 2011 8:06 AM
    Thursday, November 17, 2011 9:20 AM
  • Monday, November 21, 2011 4:39 PM
  • Hi Luis,

     

    From your logs:

    [11/21/2011, 11:20:40] Returning IDOK. INSTALLMESSAGE_ERROR [There is a problem with this Windows Installer package. Please refer to the setup log for more information. ]

    11/21/11 11:20:39 DDSet_Error: Failed to install assembly C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll. IAssemblyCache->InstallAssembly() returned -2147024891.

    11/21/11 11:20:39 DDSet_Error: Failed to install assembly 'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.VisualC.STLCLR.dll' because of system error: Access is denied.

    For the error code “-2147024891”, it means “Access is denied”.

     

    First, I recommend you take a look at this page: http://support.microsoft.com/default.aspx?scid=2263996 .

     

    Second, you can try these:

    ·         Click Windows button and type 'regedit' in search bar.

    ·         Click 'regedit' in search results

    ·         Navigate to following registry hive:

    HKLM\Software\Microsoft\Windows\CurrentVersion\Installer

    Check if following registry keys have correct values:

    ·         MsiExecCA32 should end with \Windows\syswow64\msiexec.exe

    ·         MsiExecCA64 should end with \Windows\system32\msiexec.exe

    Re-run setup program after trying troubleshooting steps.

    You can refer to this page: http://blogs.msdn.com/b/varungupta/archive/2010/06/22/troubleshooting-net-framework-4-install-failures.aspx?PageIndex=2

     

    Third, make sure your user account is in Administrators group. To do so: Right-click the installer -> Properties ->Security tab -> add your account with Full control.

     

    If you fail again, please collect a fresh log for further diagnose.

     

    If you have any other concerns, please feel free to let me know.

     

    Best Regards,


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    • Marked as answer by Alexander Sun Tuesday, November 29, 2011 3:11 AM
    Tuesday, November 22, 2011 8:51 AM
  • I am also having issues, 0x80070643.

    Ran the standalone installer. My user account is in the local administrators group, virus protection is disabled, I tried to install using Run As Administrator

    Zip file of temp directory is at

    https://skydrive.live.com/#cid=E76491ADA626B7DD&id=E76491ADA626B7DD%21153, temp.zip.

    I appreciate ALL help!

    Monday, September 24, 2012 2:33 AM