none
Azure SDK 2.6 reports "You must enable Visual Studio Web Development Feature in Visual Studio 2015" ... what is that? RRS feed

  • Question

  • I've installed Visual Studio 2015 Professional and am now trying to install Azure SDK 2.6 using Web PI. Web PI reports: 

    "You must enable Visual Studio Web Development Feature in Visual Studio 2015 or install Visual Studio Express 2015 before you can install this product. To enable Web Development Feature in Visual Studio 2015, refer to Visual Studio 2015 help. To install Visual Studio Express 2015 for Web, please use Web Platform Installer's products list or search box"

    Within Visual Studio 2015 exactly which feature do I need to add? I already have: 

    • Visual F#
    • Python Tools for Visual Studio
    • Lightswitch
    • MS Office Developer Tools
    • MS SQL Server Data Tools
    • Microsoft Web Developer Tools 
    • PowerShell Tools for Visual Studio
    • Silverlight Development Kit
    • Git for Windows
    • GitHub Extension for Visual Studio

    I have NOT installed:

    • Visual C++
    • ClickOnce Publishing Tools
    • Windows 8.1 & Windows Phone 8.0/8.1 Tools
    • Cross Platform Mobile Development
    • Visual Studio Extensibility Tools

    I'm on Windows 8.1 Pro, I previously had the VS 2015 RC (Enterprise) installed but uninstalled it before installing VS2015 RTM Professional. I have VS 2013 Pro and VS 2010 installed, and the Azure 2.6 SDK for 2013 installed. I was able to install SDK 2.7 for 2015 just fine, but I need SDK 2.6 as it's used by several solutions I work with.

    Cross-posted in Azure forums here (although I don't see any Azure forum for install issues so that might not be the best place for it).

    many thanks for any help, 

    Rory


    • Edited by Rory PS Monday, July 27, 2015 7:18 PM
    Monday, July 27, 2015 12:28 PM

Answers

  • I checked with the team, and the release managers for the team. A side-by-side install of the 2.6 and 2.7 SDKs isn't supported. You can have 2.7 for 2013 and 2015 on the same machine, or 2.6 for 2013 and 2015 on the same machine, but the 2.6 and 2.7 SDKs aren't side-by-side compatible. 
    Tuesday, July 28, 2015 4:35 PM

All replies

  • (If there's a better forum for SDK Install Issues please let me know, I couldn't find any that seemed appropriate)

    I've installed Visual Studio 2015 Professional and am now trying to install Azure SDK 2.6 using Web PI. Web PI reports: 

    "You must enable Visual Studio Web Development Feature in Visual Studio 2015 or install Visual Studio Express 2015 before you can install this product. To enable Web Development Feature in Visual Studio 2015, refer to Visual Studio 2015 help. To install Visual Studio Express 2015 for Web, please use Web Platform Installer's products list or search box"

    Within Visual Studio 2015 exactly which feature do I need to add? I already have: 

    • Visual F#
    • Python Tools for Visual Studio
    • Lightswitch
    • MS Office Developer Tools
    • MS SQL Server Data Tools
    • Microsoft Web Developer Tools 
    • PowerShell Tools for Visual Studio
    • Silverlight Development Kit
    • Git for Windows
    • GitHub Extension for Visual Studio

    I have NOT installed:

    • Visual C++
    • ClickOnce Publishing Tools
    • Windows 8.1 & Windows Phone 8.0/8.1 Tools
    • Cross Platform Mobile Development
    • Visual Studio Extensibility Tools

    I'm on Windows 8.1 Pro, I previously had the VS 2015 RC (Enterprise) installed but uninstalled it before installing VS2015 RTM Professional. I have VS 2013 Pro and VS 2010 installed, and the Azure 2.6 SDK for 2013 installed.  I was able to install SDK 2.7 for 2015 just fine, but I need SDK 2.6 as it's used by several solutions I work with.

    Cross-posted in the Visual Studio forum here.

    thanks!

    Rory


    Monday, July 27, 2015 12:40 PM
  • Hi

    Could you try to install Azure SDK 2.7 instead?

    /dag

    Monday, July 27, 2015 1:06 PM
  • Ah, I should have said: I've got the 2.7 SDK installed for VS 2015 just fine. But I have solutions that depend on 2.6 so I need that too. 
    Monday, July 27, 2015 1:16 PM
  • Hello Rory PS,

    Your issue is not related to Azure webapps, you should be able to find the answer in the Visual Studio Setup and Installation forum, I am merging your thread for better audience and avoid duplication.

    Thanks,
    Syed Irfan Hussain

    Tuesday, July 28, 2015 9:08 AM
    Moderator
  • It seems more of a question for the Azure SDK team, where should that be asked?
    Tuesday, July 28, 2015 9:15 AM
  • You can access this page https://www.microsoft.com/en-us/download/details.aspx?id=46892.
    If you've installed Azure SDK 2.7,you only need to install Microsoft Azure Authoring Tools - 2.6 and MicrosoftAzureTools.VS.140
    My development environment vs2015 enterprise + Server 2012 r2, I have the same problem, but now is ok.
    You can try.

    Tuesday, July 28, 2015 3:35 PM
  • I checked with the team, and the release managers for the team. A side-by-side install of the 2.6 and 2.7 SDKs isn't supported. You can have 2.7 for 2013 and 2015 on the same machine, or 2.6 for 2013 and 2015 on the same machine, but the 2.6 and 2.7 SDKs aren't side-by-side compatible. 
    Tuesday, July 28, 2015 4:35 PM
  • I was experiencing this same error, but I had not yet installed either the 2.6 or 2.7 SDK. I fixed it by installing the Azure SDK 2.6 for VS 2013 and my project compiled in both vs 2013 and 2015.  
    Thursday, July 30, 2015 9:31 PM
  • The new installation of VS2015, not installed version 2.7 SDK. You can not install version 2.6 SDK, an error message must enable web development feature. So this is a bug
    Friday, July 31, 2015 2:04 AM
  • Agreed, had the same problem, unable to install Azure SDK 2.6 with VS 2015.

    Having to install 2.7 and upgrade my project.

    Saturday, October 10, 2015 10:15 PM
  • Thanks, this fixed the issue for me with 2.8 and 2.6.
    • Proposed as answer by rhgraphic Saturday, June 25, 2016 11:19 AM
    Wednesday, February 3, 2016 8:57 PM

  • hi. I have also the problem but I cannot to solve it. What did you do for fixing the problem, pls?
    Saturday, June 25, 2016 11:20 AM
  • This worked for me:

    Control panel -> Uninstall a program -> Microsoft Visual Studio Enterpise 2015 with Updates -> Change ->Modify - Add Microsoft Web Developer Tools feature.

    I also had to mount ISO file I used to install Visual Studio 2015 in the first place. It's likely possible to download missing packages from internet.



    Friday, September 9, 2016 12:29 PM