none
TFS 2015 XML Build Definition Interactive Mode Not Elevated

    Question

  • 1w I have configured a windows 10 machine to run XML build definition on TFS 2015 (We still need old xml build definition for our build system). And we want to run the build with 'interactive mode' because of we have UI unit tests. I launch the TFS server admin console as the admin, set the admin account to connect to tfs server and checked 'Run the Service Interactively'. But when I start the build I noticed that interactive command line is not elevated (not running as admin). some of the project failed to build because of it's not building on administrative command prompt. what could be the reason for this?

    Tuesday, March 06, 2018 3:45 PM

All replies

  • Hi Danushka Gunathilaka,

    Welcome to MSDN forum.

    This forum is about the MSBuild(Discuss the Microsoft build engine aka MSBuild. Topics including: usage of MSBuild, build customization, and MSBuild extensibility via tasks, loggers and hosting.), as your issue is more related to the TFS, so I could not provide a directly solution for this issue.

    If possible, you can try to change the log on user account with admin. go to the Services on the TFS Build machine, and find the node "Visual Studio Team Foundation Build Service Host"->click Properties->Log on->Type the .\Administrator user account.

    See following thread for some more details:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/ef413438-ce29-47f5-90b6-3fe88da1ecd3/build-controller-interactive-mode-problem?forum=tfsbuild

    If above not help you, I suggest that you can open a new thread on the stackoverflow with TFS tag for better support.

    Thanks for your understanding and cooperation.


    MSDN Community Support Please remember to click Mark as Answer. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, March 07, 2018 6:26 AM