can't find certificate?


  • Hi everyone. I am in need of certificate help. I have a service that works fine in development. I created temp certificates with makecert and i'm using peer trust. I go to deploy it to our test servers and change the name of the ssl certificate that were setup on the server for wcf. Say the name is "". Here is what the securitycredentials looks like in my web.config:
                  <authentication certificateValidationMode="PeerTrust" trustedStoreLocation="LocalMachine"/>
                <serviceCertificate findValue="CN=" storeLocation="LocalMachine" storeName="My"/>

    I keep getting an error when i try to start up the service stating it can't find the certificate.

    I checked the certificate on the server. It is installed  on the localmachine/personal store. I thought maybe it was case sensitive so i tried to make sure the case was exact and it still couldn't find it. I also tried to remove the "CN=" part eventhough i was pretty sure it was ok and i still couldn't find it. Please not this is on Windows 2008 Server and its running under IIS. I would assume if it was a security problem (current user doesn't have access to the private key of the certificate) then it would give me some type of security exception and not an exception that it can't find the certificate. Anyone have any ideas? Am i doing something wrong.

    Friday, July 11, 2008 7:33 PM


All replies