none
debug lightswitch html client using chrome RRS feed

  • Question

  • we are only allowed to use IE 8 and Chrome in our company. IE8 is the default browser set in group policy and cannot be changed to Chrome. I cannot figure out how to make chrome come up when i hit F5 in VS 2012. Any help would be greatly appreciated. Thank you.
    • Edited by Fabian Monday, October 7, 2013 11:28 PM
    Monday, October 7, 2013 11:25 PM

Answers

All replies

  • Hello

    I take it you have tried selecting the small downward pointing arrow next to Internet Explorer and then selected Google Chrome? (See Screenshot below)

    Select Choice Of Browser

    You can also change the default browser if you like by selecting the browse With option and then selecting the browser you want to be a default.

    HTH :)


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    • Proposed as answer by Otis Ranger Tuesday, October 8, 2013 11:20 AM
    • Unproposed as answer by Fabian Tuesday, October 8, 2013 5:58 PM
    Tuesday, October 8, 2013 11:19 AM
  • Hi Otis Ranger

    I have seen this option in web apps. However I don't see this option in a Visual Studio Lightswitch HTML project. 

    Do you know how to get this to work in VS lightswitch HTML project?

    Thank you.


    Tuesday, October 8, 2013 4:25 PM
  • Hello

    You are right, my screenshots were from a different app :$ However, I think that this blog post from the great Jewel Lambert could help you out.

    http://jewellambert.com/how-to-change-the-default-webbrowser-for-debugging-lightswitch-apps/


    If you found this post helpful, please mark it as helpful. If by some chance I answered the question, please mark the question as answered. That way you will help more people like me :)

    • Marked as answer by Fabian Wednesday, October 9, 2013 7:00 PM
    Wednesday, October 9, 2013 12:32 PM
  • It is now almost working.

    In my VS LightSwitch HTML client project i had to change to FileView. I can then right click on any of my Server side folders to get to click the Browse With menu item. So i was able to change my Default Browser to Chrome. Now when i hit F5 the app loads in Chrome.

    Break points are hit on the server side code. However breakpoints i set in the HTMLClient are not hit when i use chrome.
    I know break points are hit with IE10 on my machine at home. Is java script debugging only working in IE?

    When I right click HTMLClient side folders the Browse With menu item is there but when i click it nothing happens. A bug?

    I'm going to mark your post as answer but just hoping that i can get java script debugging to work since it's more important than the server side debugging.
    Any tips would be great.

    Thank you so much for your help.

    Wednesday, October 9, 2013 7:00 PM