locked
Visual Studio 2005 has compatibility issues with Windows7(64 bit) RRS feed

  • Question

  • I have installed VS 2008 and 2010 in my 64 bit windows7 machine. I need to have VS 2005 as well, and installed without any issues. After installation, while I tried to open the IDE, it is showing the below error.

    If I ignore this and try to run the application, Am getting another error as shown below.

    Please help me on this. I need all the three versions to run properly.

    Thanks,
    Johnson

     
    Thursday, March 22, 2012 5:55 AM

Answers

All replies

  • Hi Johnson, you need to install the following below in the following order to get VS 2005 running properly on Windows 7.

    1. VS 2005 SP1 - http://www.microsoft.com/download/en/details.aspx?DisplayLang=en&id=5553

    2. Visual Studio 2005 Service Pack 1 Update for Windows Vista - http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7524

    • Edited by systemx Thursday, March 22, 2012 7:00 AM
    • Proposed as answer by Barry Wang Friday, March 23, 2012 6:01 AM
    • Marked as answer by Barry Wang Friday, March 30, 2012 7:40 AM
    Thursday, March 22, 2012 6:59 AM
  • Hi Johnson,

    Welcome to the MSDN forum.

    I agree with what systemx said. Please have a look at this blog:

    http://msdn.microsoft.com/en-us/vstudio/aa948853

    In order to use Visual Studio 2005 on Win7, you should have Visual Studio 2005 Service Pack 1 and the Visual Studio 2005 Service Pack 1 Update for Windows Vista installed.

    Additionally, Visual Studio 2005 is not supported on this forum since it is out of lifcycle. If you want to get better support here. I suggest you try more higher versions of Visual Studio.

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, March 23, 2012 6:01 AM
  • Has anything changed on this process. When I go to install VS2005 SP1

    using the link you provided I get:

    I have also tried the Windows Vista update and it does the same.

    Does 64 bit machine make a difference.
    • Edited by Logixology Wednesday, March 20, 2013 12:56 AM
    Wednesday, March 20, 2013 12:55 AM
  • I have the same problem. Patch will not install and I get the exact same message as above. Any help?
    Friday, July 26, 2013 6:55 PM
  • For what it is worth:  I just installed VS2005 on my 64bit Win7 machine.  I got 3 different popups during installation saying there were compatibility issues during installation, and 'run program' in each instance allowed the installation to finish.  After this I was able to install both of the above mentioned updates in order with no errors.  Once I get my other stuff installed to use if I find an issue with actually using VS I will reply back, and sorry this isn't particularly helpful, but just fyi so you know it shouldn't be impossible.  The OP was an error message during VS installation itself, and I did not get that.  So I assume the patch itself is not the issue - the installation has already failed.  Anyway, hope you get it working!
    Wednesday, August 7, 2013 9:01 PM
  • Hi CGgoose, just wondering if you've found any issue with VS2005 after you got it installed on a 64bit Win7 machine. I was also able to install the 2 Service Packs, but find that it doesn't work. I was able to create a TI Project using Win-XP, but with Win7 I get an Object reference not set to an instance of an object message while using the TI Project wizard. Thanks Jeff N
    Wednesday, November 27, 2013 7:39 PM
  • The link above for SP1 may not be the one you want (especially if you get a patch version mismatch dialog), it's for the Standard/Pro and Team Suite versions of VS.  That's most likely why Logixology and aweiridof got the version mismatch errors and couldn't get it to work.  You're gonna want to check the exact product you've installed and find the matching flavor of SP1.  If you have VS 2005 Express Edition, you're going to want to go here:

    http://www.microsoft.com/en-us/download/details.aspx?id=804

    (Also, that's a service pack for multiple 'sub-flavors' of original installation, and so there are multiple downloads available...you'll need either the one specific to your install or if you're unsure download them all and exactly one should work without a mismatch error, which for me was the one associated with KB926748.) The other links systemx provided should work though (and thanks for them and the rest of the help in here!), they're not previous-install-flavor-specific.


    Thursday, January 30, 2014 12:58 AM